If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Search pane shows inconsistent search results from AMO

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
API
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Details

(Whiteboard: [4b2])

(Reporter)

Description

7 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

Not sure yet if this is a bug on the client or server side but the results differ. See the following example:

Steps:
1. Open the add-ons manager
2. Search for "feed" => Feedback and Reliby ("feeds" in description) are shown
3. Search for "eed" => Only Feedback is shown
4. Search for "iby" => Reliby is shown
5. Search for "Book" => Reliby is not shown ("Bookmark" in description)

Those are only some examples. There are a dozen more which will limit users to find their wanted add-ons.

If this is a bug on the server side can we move it to the appropriate component?
I'm pretty sure this is a dupe of an existing bug. The problem is simply that AMO returns results based on relevance to the search terms, there are many results more relevant than Reliby for those searches where you didn't see it and the majority of them are incompatible with your version of Firefox and so hidden from you.
(Reporter)

Comment 2

7 years ago
Well, but in such a case I would expect to have at least a full list of search results. But doing the steps above I was way under the max limit. For some searches I even don't get any result returned.
There are lots more incompatible results on AMO than there are compatible ones right now. We could increase the number of results we request from the API (currently at 30 I believe) in the hopes of getting more compatible ones but I'm not sure how that affects load on AMO. This is basically only a problem with nightly/beta versions though.
(Reporter)

Comment 4

7 years ago
We have 15 results at the moment. But my request is not to increase the max number of results, but to show the correct results as long as the number of results < maxResults.

Here one example in detail:

1. Searching for "feed" returns: Feedback, Reliby, and Newsbar. The last two add-ons have "feed" in their description.

2. Searching for "fee" returns: Feedback. There is no result from AMO returned. 

First I thought we had a minimum limit of characters before we start to search on AMO but that's not the case. So if we have more results for "fee" as for "feed" we should show those until we reach the max count. But returning no results isn't helpful at all.
(In reply to comment #4)
> We have 15 results at the moment. But my request is not to increase the max
> number of results, but to show the correct results as long as the number of
> results < maxResults.

We request 30 results from AMO and show the first 15 that are compatible and not already installed.

> Here one example in detail:
> 
> 1. Searching for "feed" returns: Feedback, Reliby, and Newsbar. The last two
> add-ons have "feed" in their description.
> 
> 2. Searching for "fee" returns: Feedback. There is no result from AMO returned. 

Over to the AMO team then, fee seems to return only 19 results through the API, not including those that you are looking for for some reason.
Component: Add-ons Manager → API
Product: Toolkit → addons.mozilla.org
QA Contact: add-ons.manager → api
Version: Trunk → unspecified

Updated

7 years ago
blocking2.0: ? → -
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.