Closed Bug 581290 Opened 10 years ago Closed 9 years ago

Android debug builds

Categories

(Release Engineering :: General, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mwu, Assigned: aki)

References

Details

Attachments

(2 files)

I think it would be nice to have debug builds of android so something can turn red if debug builds are broken.
assign to bear at his request.
Assignee: nobody → bear
It would be nice to get android debug builds if only so that we can run reftests/crashtests on them.  (I don't know the bug # for that work.)  Reftests and crashtests track the number of assertions triggered by tests, which is extremely useful, but that code only works in debug builds.
I just landed a patch that I had to back out due to mysterious crashes on Maemo Talos, and it took me quite a while to work out the problem.  If debug builds were on, the tests would have hit an assertion that I put in and the problem would have been much more obvious.
Assignee: bear → aki
got another regression in bug 628372 that this would have caught.

Aki, got an ETA for this?
Started on a patch last week that got put aside to deal with bustage.
Assuming things go well, this week.
Turns them on for m-c, m-aurora, m-beta, m-2.1 as a depend build.
Adds mozconfigs as appropriate.

I will stage this.
Comment on attachment 526871 [details] [diff] [review]
android debug configs

Went green in staging.
Attachment #526871 - Attachment description: [untested] android debug configs → android debug configs
Attachment #526871 - Flags: review?(jhford)
Attachment #526872 - Attachment description: [untested] android debug generateMobileBranchObjects → android debug generateMobileBranchObjects
Attachment #526872 - Flags: review?(jhford)
Attachment #526871 - Flags: review?(jhford) → review+
Attachment #526872 - Flags: review?(jhford) → review+
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.