'Mark as read' sets all to 'read' when range selected and 'automatically mark as read'

RESOLVED DUPLICATE of bug 575732

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED DUPLICATE of bug 575732
8 years ago
7 years ago

People

(Reporter: dcm-mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.11) Gecko/20100711 Thunderbird/3.0.6

This is a user interface problem, not a bug.

If "Automatically mark as read" is enabled, and one selects the start and end of a range to mark all these messages as read, the action of putting the focus on the first message ends up automatically marking them it read. So when one then holds shift, clicks on the last email in the range, right-clicks and selects "Mark", the next submenu already has a check mark beside "As read", even if only the first and last messages in the range have been read. So to mark the entire range as read you need to uncheck and then re-check the "as read' menu item. 

The problem is a compound issue of the "As read" entry serving as both a status indicator and a command activator, coupled with the uncertainty of whether it reflects the status of the entire range or just the first item in the range, and further complexified (great non-word!) by the automatic behavior of "Automatically mark as read". Too much going on!

Suggestion: Add a submenu item "As not read" above or below "As read" to cover both cases. Show a checkmark beside either "As not read" or "as read" if and only if all the emails in the range fit the criteria - a grey box beside each would also be OK if the range has a mix. 


Reproducible: Always

Steps to Reproduce:
1. Set "Automatically mark as read"
2. Click the first entry of a range of emails that are not read - note the first entry automatically gets marked as read
3. Hold shift
4. Click the last email in a range of unread email.
5. Right click to pop up submenu
6. Select "Mark"
7. Note submenu has check beside "as read' even though all but the first are not read
8. Click on "as read" and note the range of emails is now marked as not read (i.e. only the first email in the list had its state changed, from read to not read). This is the opposite of what one usually tries to do (i.e. one usually wants to mark a range as read, not as unread.)
9. Repeat step 5,6,8 above to finally end up with range marked as read.

Actual Results:  
See details and Steps to reproduce

Expected Results:  
See above

Comment 1

8 years ago
thanks for the excellent description. 

this is a duplicate of a bug/class of bugs wherein the context menu action item always takes the attributes of the first select message. For multi select, https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc=mult%20select%20&field0-0-0=short_desc&short_desc_type=allwordssubstr&longdesc=first&type0-0-0=nowordssubstr&value0-0-0=cert&component=Folder%20and%20Message%20Lists&component=Mail%20Window%20Front%20End&resolution=---&longdesc_type=allwordssubstr&product=Thunderbird list several and bug 327828 strikes me as the one I have always referred to (but there might be a better one)

also related to this bug https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced;short_desc_type=allwordssubstr;resolution=---;type0-0-0=nowords;value0-0-0=count%20counts;product=MailNews%20Core;product=Thunderbird;short_desc=mark%20select%20first

please close this as a duplicate of the best matching bug.
Component: Toolbars and Tabs → Folder and Message Lists
QA Contact: toolbars-tabs → folders-message-lists
Whiteboard: dupme

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575732

Updated

7 years ago
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.