The default bug view has changed. See this FAQ.

Need warning for destructive retention settings for POP (Disk Space) and IMAP (Synchronization & Storage) accounts

RESOLVED FIXED in Thunderbird 43.0

Status

MailNews Core
Account Manager
--
critical
RESOLVED FIXED
7 years ago
10 months ago

People

(Reporter: Ryan Williams, Assigned: aceman)

Tracking

(Blocks: 1 bug, {dataloss, uiwanted, ux-error-prevention})

Trunk
Thunderbird 43.0
dataloss, uiwanted, ux-error-prevention
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [RESTORE FROM YOUR BACKUP])

Attachments

(1 attachment, 1 obsolete attachment)

4.73 KB, patch
Paenglab
: ui-review+
Details | Diff | Splinter Review
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.11) Gecko/20100713 Thunderbird/3.0.6

The second set of radio buttons in the Synchronization & Storage section can cause data loss, because it permanently deletes messages from the server.  It needs a warning to the user when setting it to anything other than "Don't delete any messages".  The warning should say something along the lines of "Changing this setting will result in the permanent deletion of <NUM> emails from both the server and your local machine.  You cannot undo this action.  [OK] [Cancel]"

The problem is compounded because it's right below the settings for the local disk utilization, and are grouped under the same heading, leading one to believe that all such settings pertain only to the local disk.  Even worse, the deletion happens silently at some future point, so you can change the setting, observe no apparent change, and some indeterminate amount of time later discover massive data loss.

I personally just lost about ten thousand emails due to this problem.  I looked at that dialog many times, and thought the text was ambiguous.  Thunderbird is so replete with warning dialogs that I thought it was impossible for me to accidentally delete anything without triggering at least a slight peep.

Reproducible: Always

Steps to Reproduce:
1.  Move radio button to "Delete all but the most recent [1000] messages"
2.  Click OK
Actual Results:  
Nothing obvious happens immediately.  Eventually (days later, perhaps, I don't know) all but 1000 messages are irretrievably gone.

Expected Results:  
A warning should pop up indicating that messages are going to be deleted from the server, and that this is an action that cannot be undone.
(Reporter)

Updated

7 years ago
Keywords: dataloss, uiwanted
(Reporter)

Updated

7 years ago
Version: unspecified → 3.0
Summary: Need warning for destructive Synchronization & Storage setting → Need warning for destructive Synchronization & Storage setting affecting pop account
Whiteboard: dupme?
Ryan, sorry you had difficulty. "Steps to Reproduce:" should actually include the _action_ steps prior to seeing the issue.

Please retest with version 3.1.1 - sync and storage may have changed. And the  migration asst has different settings. Please post your findings.
(Reporter)

Comment 2

7 years ago
The Synchronization & Storage panel in Account Settings is unchanged in 3.1.1, so it still has this problem.  Bumped version in the report.
Version: 3.0 → 3.1
(Reporter)

Comment 3

7 years ago
Not
(Reporter)

Comment 4

7 years ago
Heh, not sure where that "not" came from!  In any case, this has nothing to do with the Migration Assistant.  I'm unclear how to better phrase my steps to reproduce.  Perhaps borrowing from bug 531088:

1. Default install TB to 3/3.1.1, set up IMAP account to a server that has tens of thousands of messages that have been nicely preserved by your devotion to TBird over the past 5 years.
2. Observe that your hard disk is now full and try to figure out what setting keeps this blasted thing from caching every email including spam.
3. Move radio button in "Synchronization & Storage" to "Delete all but the most recent [1000] messages" thinking that it means "delete local copies".
4. See no confirmation dialog, observe that all emails are still present and accounted for.
5. Start open a new email composition window by accident, close it and observe dialog asking you to save the *completely empty* draft email, think "wow this software is so paranoid about data loss that it warns you in situations where it doesn't even make sense".
6. Observe that all emails are still present.
7. Go about your business for a few days/weeks.
8. Hope you have a good backup system for keeping historical copies of your data, because most of your email is gone.

Comment 5

7 years ago
"Summary" says "pop account", but there is no "Synchronization & Storage" setting for a POP account.  Description/comments correctly refer to IMAP.  

Warning should also apply to POP accounts, though, if "Disk Space" settings are altered.  The same wording is used above the options in "Disk Space", but are the emails REALLY deleted on the server ?  If so, why ?  Shouldn't "Disk Space" ONLY apply to local storage, and "Server Settings" control "Server storage" (for the POP case, anyway) ?
Parkhideh, can you help clarify what might be useful behavior here? Is there not another bug that addresses this?

Comment 7

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Parkhideh, can you help clarify what might be useful behavior here? Is there
> not another bug that addresses this?

Wayne, please read comments made in 2007; bug #360300.  Never mind the "Fetch Header" parts, but read the "delete" from disk and server sections.

I will repeat myself.  Thunderbird has two sections as options on removing items from disk and server.  One is checkbox under Tools / Account Settings / Server Settings;  the other has been mentioned here radio buttons under Tools / Account Settings / Disk Space;  there is no good reason why there is no menu for SERVER ONLY options and one menu for DISK ONLY activity.  As Ryan has implied we need a confirmation; however, my preference is that each menu then have an APPLY button instead of a confirmation pop up that is suggested.
Now Wayne tell me in earnest;  will we still have these issues in 2016?  :)
(Assignee)

Comment 8

5 years ago
Bwinton, any ideas here?
Summary: Need warning for destructive Synchronization & Storage setting affecting pop account → Need warning for destructive Synchronization & Storage setting affecting pop and Imap accounts

Updated

4 years ago
Summary: Need warning for destructive Synchronization & Storage setting affecting pop and Imap accounts → Need warning for destructive retention settings for POP (Disk Space) and IMAP (Synchronization & Storage) accounts

Comment 9

4 years ago
Based on Thomas' initiative, I've changed the title again with clarification of the different panel names for POP and IMAP accounts, also made it specific to the retention settings mentioned in the original description. This is different from bug 531088 for the "leave message on server" settings, and also different from the "fetch headers" issue for which bug 360300 was filed, thus a distinct bug.

Confirming as I don't find any duplicate, and this has been around long enough. Posting a first-use warning when switching from "Don't delete any messages" to any of the other retention settings which may delete messages (be it locally or also from the server) sounds reasonable and should be feasible.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: ux-error-prevention
OS: Linux → All
Hardware: x86 → All
See Also: → bug 531088
Whiteboard: dupme?
Version: 3.1 → Trunk

Comment 10

4 years ago
Bug 765775 shows another instance where synchronization and retention settings were mixed up and lead to accidental deletion of a substantial number of messages.
(Assignee)

Comment 11

4 years ago
I still do not understand the problem here. The option says "delete all but X messages". So what is the problem when it does that, even though later? Can somebody elaborate? Is is because some local vs. server distinction?

Comment 12

4 years ago
Despite clarification of the labels in bug 410597 there is apparently still some confusion between synchronization (IMAP), leaving messages on the server (POP), and the retention settings. Thus, users may pick one where they mean the other, which in the case of the retention settings has major impact as it deletes /both/ local and remote versions in contrast to the other settings.

This is about a "Hey, this may wipe out all of your messages, are you sure that you want to do this?" type of warning for the user to ensure that this is actually the intention. I'd suggest a first-use warning or a "don't show again" box dialog.

Alternatively, the retention settings could be hidden in a secondary dialog which can be reached by an "Advanced" button in the main panel, to make it more difficult to activate that function accidentally (and would also allow to be more verbose in explaining what the function does, if that's felt to be necessary).
(Assignee)

Comment 13

4 years ago
But the POP3 retention settings mention in the label, that it will delete messages on the server too.

But I'd be OK with adding a warning dialog if bwinton confirms this request.
But I think the "don't show again" checkbox must be tied to a pref and that would be overkill for this feature. I'd need to know what IanN thinks.
Component: Account Manager → Account Manager
Flags: needinfo?(bwinton)
Product: Thunderbird → MailNews Core
(Assignee)

Updated

4 years ago
Flags: needinfo?(iann_bugzilla)

Comment 14

4 years ago
(In reply to :aceman from comment #13)
> But the POP3 retention settings mention in the label, that it will delete
> messages on the server too.
> 
> But I'd be OK with adding a warning dialog if bwinton confirms this request.
> But I think the "don't show again" checkbox must be tied to a pref and that
> would be overkill for this feature. I'd need to know what IanN thinks.

Agreed, if you do have this sort of warning message it should be linked to a pref (per account?), but as you say it might overkill.
Flags: needinfo?(iann_bugzilla)

Comment 15

4 years ago
That's a setting which is not likely to be changed very frequently, I'd assume. Thus, in contrast to reoccurring actions where a pop-up warning becomes rather annoying, it should be fine to show the warning whenever you switch away from the safe "Don't delete any messages" setting to one of the other choices.

Note that the same dialog is in the Folder Properties as well, but a bit more complicated given that the account's settings may be inherited or overridden. Those settings are less likely to run into by accident as they have their own dedicated tab, thus I think the warning should be sufficient for the main account settings in am-offline.* without adding it to folderProps.* as well.
(Assignee)

Comment 16

4 years ago
(In reply to rsx11m from comment #15)
> That's a setting which is not likely to be changed very frequently, I'd
> assume. Thus, in contrast to reoccurring actions where a pop-up warning
> becomes rather annoying, it should be fine to show the warning whenever you
> switch away from the safe "Don't delete any messages" setting to one of the
> other choices.

Nice, similar to the warning that always appears when a pop3 account is deferred to another one.
(Assignee)

Updated

4 years ago
Assignee: nobody → acelists
Yeah, sure.  (Normally I'm against pop-ups, since people don't read them, and just click "Okay, sure, whatever", but since this is a fairly-rarely-changed feature, that shouldn't be the case here.)
Flags: needinfo?(bwinton)

Comment 18

4 years ago
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Parkhideh, can you help clarify what might be useful behavior here? Is there
> not another bug that addresses this?

Wayne, inline with comment #7;  perhaps comments 86,87 and 88 of 
"Bug 89034 - Using filters stops messages from being deleted on pop server. " belong here.

As you can see there are many bug reports that concern users on how an e-mail is removed from a POP server.  Unfortunately, they are coupled with other functions like "fetch header", "move mail" or "delete from inbox" which all report errors of either "not deleting" when asked or "deleting" when not intended, from POP server.

So, I recommend that another bug report be opened to define how a "message delete" or "message move" from POP server should be implemented; this way existing bugs would address the issue why the messages are not deleted from the POP server.

Comment 19

2 years ago
I just lost over a hundred thousand personal and business messages (7 years worth) due to this problem. A pop up would have saved me.

I was trying to save space on my hard drive and didn't want or expect any messages to be removed from my IMAP server. This is a big enough error to turn me away from Thunderbird forever. It's especially galling that this has been a known problem for over two years and the fix is simple.
Whiteboard: [RESTORE FROM YOUR BACKUP]

Comment 20

2 years ago
@WAYNE: YOU DENY THERE IS A PROBLEM???
(Assignee)

Comment 21

2 years ago
Yes, there is a problem that users do not read the "both local copies and originals ON THE REMOTE SERVER".

But I think we got all the replies here so let's add the popup which asks the user again.
(Assignee)

Comment 22

2 years ago
Created attachment 8648303 [details] [diff] [review]
patch

So let's try the warning dialog.
Attachment #8648303 - Flags: ui-review?(bwinton)
Attachment #8648303 - Flags: review?(mkmelin+mozilla)
Attachment #8648303 - Flags: review?(iann_bugzilla)
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED

Comment 23

2 years ago
Comment on attachment 8648303 [details] [diff] [review]
patch

>+++ b/mailnews/base/prefs/content/am-offline.js

>+function warnServerRemove(aRadio)
>+{
>+  if (aRadio.value != 1) {
>+    let prefBundle = document.getElementById("bundle_prefs");
>+    let title = prefBundle.getString("removeFromServerTitle");
>+    let question = prefBundle.getString("removeFromServer");
>+    if (!Services.prompt.confirm(window, title, question)) {
>+    // If the user doesn't agree, fall back to not deleting anything.
Nit: properly indent the comment.
>+      aRadio.value = 1;
>+      onCheckKeepMsg();
>+    }
>+  }
>+}
Attachment #8648303 - Flags: review?(iann_bugzilla) → review+

Comment 24

2 years ago
Comment on attachment 8648303 [details] [diff] [review]
patch

Review of attachment 8648303 [details] [diff] [review]:
-----------------------------------------------------------------

This looks very good. Thank you!

Comment 25

2 years ago
Comment on attachment 8648303 [details] [diff] [review]
patch

Review of attachment 8648303 [details] [diff] [review]:
-----------------------------------------------------------------

r=mkmelin with a shorter text, but I leave the text for others

::: mail/locales/en-US/chrome/messenger/prefs.properties
@@ +80,5 @@
>  
>  forAccount=For account "%S"
> +
> +removeFromServerTitle=Confirm removal of messages from server
> +removeFromServer=This setting may remove some old messages from the local storage but also from the account's server. Are you sure you want to permanently remove those messages from both locations?

may remove? ;) 

I think the text is too long, it should be something shorter so users really read it.
Attachment #8648303 - Flags: review?(mkmelin+mozilla) → review+

Comment 26

2 years ago
(In reply to Magnus Melin from comment #25)
> Comment on attachment 8648303 [details] [diff] [review]
> patch
> 
> Review of attachment 8648303 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r=mkmelin with a shorter text, but I leave the text for others
> 
> ::: mail/locales/en-US/chrome/messenger/prefs.properties
> @@ +80,5 @@
> >  
> >  forAccount=For account "%S"
> > +
> > +removeFromServerTitle=Confirm removal of messages from server
> > +removeFromServer=This setting may remove some old messages from the local storage but also from the account's server. Are you sure you want to permanently remove those messages from both locations?
> 
> may remove? ;) 
> 
> I think the text is too long, it should be something shorter so users really
> read it.

As it is concerning the remote server how about rearranging and removing some repetition:
This setting can permanently remove messages from the remote server as well as local storage. Are you sure you want to this to happen from both locations?
(Assignee)

Comment 27

2 years ago
(In reply to Magnus Melin from comment #25)
> may remove? ;) 

Yes, because depending on the values user puts in, no messages may be removed right now.

> I think the text is too long, it should be something shorter so users really
> read it.

Users were not reading the much shorter text directly in the panel. So I don't know how to force them :)

Any proposals welcome ;)
Flags: needinfo?(richard.marti)
I agree with Aceman that we are here to be explicit and attract attention for a deliberate setting which is only changed once in a long while, so I wouldn't mind a few more words if it helps to really understand the consequences.

Perhaps this?

This setting can permanently delete many messages from the remote server AND your local Thunderbird storage. After automatic deletion, you cannot recover them. Are you sure you want to proceed?

Benefits:
- permanently *delete* (removing sounds too harmless imo, although delete is more techical)
- *many* messages (yes, they might be thousands!)
- local *Thunderbird* storage (local storage is too abstract; I tried 'account' but didn't like that).
- *automatic deletion* (points out this will happen without further user action or confirmation)
- *you cannot recover them* (let's be explicit about the real problem for the user, which is not removing here or there, but removing in a non-reversable way)
- *are you sure you want to proceed?* is a default question which we have for such cases

> +removeFromServerTitle=Confirm removal of messages from server
Hmmm. I thought we're deleting local copies AND remote copies, that's why it's so harmful. So "from server" is grossly misleading again?

Perhaps this?

Confirm permanent, automatic deletion of messages

Benefits:
*permanent* - that's the keyword, hinting to non-recoverable
*automatic* - also important, it will happen silently without further user action/confirmation!
*deletion* - see above, imo more drastic/realistic than 'removing'
(In reply to Thomas D. from comment #28)
> 
> Perhaps this?
> 
> This setting can permanently delete many messages from the remote server AND
> your local Thunderbird storage. After automatic deletion, you cannot recover
> them. Are you sure you want to proceed?

I'm more for combination of Ian's and Thomas's versions:

This setting can permanently delete messages from the remote server AND your local storage. Are you sure you want to proceed?

We have already the "permanently" in this sentence, so no need to repeat it's not recoverable.

> > +removeFromServerTitle=Confirm removal of messages from server
> Hmmm. I thought we're deleting local copies AND remote copies, that's why
> it's so harmful. So "from server" is grossly misleading again?
> 
> Perhaps this?
> 
> Confirm permanent, automatic deletion of messages

A little bit lengthy but I'm okay with this.
Flags: needinfo?(richard.marti)
(In reply to Richard Marti (:Paenglab) from comment #29)
> (In reply to Thomas D. from comment #28)

OK, thanks.

Comment 31

2 years ago
(In reply to Richard Marti (:Paenglab) from comment #29)
> This setting can permanently delete messages from the remote server AND your
> local storage. Are you sure you want to proceed?

How about

  This setting will delete old messages from the remote server AND your local storage. Are you sure you want to proceed?

For all intents and purposes I think it's a "will", not a may or can.
(In reply to Magnus Melin from comment #31)
> (In reply to Richard Marti (:Paenglab) from comment #29)
> > This setting can permanently delete messages from the remote server AND your
> > local storage. Are you sure you want to proceed?
> 
> How about
> 
>   This setting will delete old messages from the remote server AND your
> local storage. Are you sure you want to proceed?
> 
> For all intents and purposes I think it's a "will", not a may or can.

+1, "will" feels much better and is still correct (it will at some point now or in the future). but we should include "permanently" because it can't be undone, unlike many other deletions.

This setting will permanently delete old messages from the remote server AND your
local storage. Are you sure you want to proceed?
(Assignee)

Comment 33

2 years ago
Created attachment 8651833 [details] [diff] [review]
patch v1.1

Thanks for fleshing out the text. Now only the ui-r+ is remaining :)
Attachment #8648303 - Attachment is obsolete: true
Attachment #8648303 - Flags: ui-review?(bwinton)
Attachment #8651833 - Flags: ui-review?(richard.marti)
Comment on attachment 8651833 [details] [diff] [review]
patch v1.1

Text looks good in dialog.
Attachment #8651833 - Flags: ui-review?(richard.marti) → ui-review+
(Assignee)

Comment 35

2 years ago
Thanks.
Keywords: checkin-needed

Comment 36

2 years ago
https://hg.mozilla.org/comm-central/rev/8fe4ce806f4b680f846ff16417c0c6d6942cba39
Bug 582170 - warn user that messages will be removed from server for some retention options. ui-r=Paenglab, r=mkmelin, r=IanN a=aleth CLOSED TREE

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0
Duplicate of this bug: 668169
Duplicate of this bug: 746350
(Assignee)

Updated

10 months ago
Blocks: 746350

Updated

10 months ago
Depends on: 1280058
You need to log in before you can comment on or make changes to this bug.