Sort order of unsorted bookmarks is wrong; should be newest to oldest, or switchable

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
8 years ago
6 years ago

People

(Reporter: caywood, Unassigned)

Tracking

unspecified
Future
All
iOS 4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
When a frequent use case for Firefox Home is "bookmark something on the desktop, then read it on mobile" you shouldn't have to scroll through a million old unsorted bookmarks to get to your newest bookmarks.

I understand that in Firefox (desktop) that's the order the bookmarks are stored, as viewed in Organize Bookmarks. But Firefox (desktop) also has the "Recently Bookmarked" folder.

This is the major flaw I've observed in switching from the Delicious app, and it's a really easy fix.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538017
Ugh, just realised this is about Fx Home, so possibly it's not a dupe of bug 538017.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: DUPLICATE → ---
(Reporter)

Updated

8 years ago
Depends on: 538017

Comment 3

8 years ago
(In reply to comment #2)
> Ugh, just realised this is about Fx Home, so possibly it's not a dupe of bug
> 538017.

Fx Home doesn't do any sorting on it's end, so it will likely just take whatever the server hands it.
Target Milestone: --- → Future
The Firefox Home project has been retired, and Mozilla will no longer invest in future work on this project [1]. All bugs related to Firefox Home are being mass resolved.

For those interested in continuing work on this app, the source code for Firefox Home is available on Github [2].

[1] http://blog.mozilla.org/services/2012/08/31/retiring-firefox-home/
[2] https://github.com/mozilla-services/ios-sync-client
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.