Fix the URL in the <reviews> element

RESOLVED WORKSFORME

Status

P1
normal
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: bparr, Assigned: kumar)

Tracking

unspecified
5.12.7

Details

(Reporter)

Description

8 years ago
In version 1.5 of the API, the text content of the <reviews> element is a URL. Currently, following this URL lands you on the main page for the add-on. It should instead lead you to the "Reviews for [Add-on Name]" page.

For example:

API result: https://services.addons.mozilla.org/en-US/firefox/api/1.5/addon/6622
API <reviews> URL: https://addons.mozilla.org/en-US/firefox/addon/6622/reviews/?src=api (ends up on main page for the add-on)
Expected Review Page: https://addons.mozilla.org/en-US/firefox/reviews/display/6622
What is the deadline for this fix?
Depends on: 557879
I think so long as it is fixed by the time Firefox 4 is released that should be fine, so that would be around start of October.
blocking2.0: --- → final+

Comment 3

8 years ago
Dave says this doesn't need to block, although we still want it.
blocking2.0: final+ → -

Updated

8 years ago
Target Milestone: --- → 5.12.7
Priority: -- → P1
Assignee: nobody → kumar.mcmillan
It looks like this somehow fixed itself.  I went through the steps to reproduce above and the URL from <reviews> in the API response lands on 'Reviews for DOM Inspector', as requested.

Did I miss something?  If so, please reopen.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(In reply to comment #4)
> Did I miss something?  If so, please reopen.

The bug was probably filed while we were transitioning reviews from remora to zamboni.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.