Closed Bug 582702 Opened 9 years ago Closed 9 years ago

Move Undo Close Tab option on tab context menu

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0b8
Tracking Status
blocking2.0 --- final+

People

(Reporter: polidobj, Assigned: fryn)

References

Details

Attachments

(1 file)

I think having the Undo Close Tab option being between the Close Tab option and Close Other Tabs option is a bad combination when it comes to errors.  Erroneously selecting the Close Tab option isn't so bad since you can just Undo Close that tab.  But doing the same with the Close Other Tabs could be a big problem if you have a large amount of tabs open.

I erroneously clicked on the Close Other Tabs option and closed many tabs when I intended to undo close a tab.  And I could only undo about 8 or 9 of those tabs that closed.

I'm not sure what should be done to mitigate this problem.  It could be as simple as move the Undo Close Tab option above the Close Other Tabs option.  But I think ideally those two iptions should not be next to each other.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581913
How is this a duplicate?  I'm not talking about the new tab button?
It's about the context menu (reload tab, open in new window, ...). It appears in the entire tab bar, not just on top of the new tab button. The title of that bug is a bit wrong.

Note that Firefox 4.0 currently has a bug and doesn't show the context menu at all on top of that button.
Duplicate of bug: 581646
Reopening this bug since the bug it was duped to went nowhere and I didn't see how it was the same in the first place.
Status: RESOLVED → REOPENED
blocking2.0: --- → ?
Ever confirmed: true
Resolution: DUPLICATE → ---
I'm asking for blocking to avoid dataloss.  A few times I've hit Close Other Tabs when I meant to hit Undo Close Tab.  And I could only undo close about 8 of those tabs that got mistakenly closed.
I agree that it's an awkward placement that can cause problems. Marking blocking+ and cc'ing Alex to get some UX input on it.
blocking2.0: ? → final+
Keywords: uiwanted
The core of the problem is that we don't have a good way to undo the action "close other tabs."  That is what we really need to address, even if we shuffle the order of undo, people are still going to accidentally hit close other tabs when they intended to hit the command next to it (at the moment this is only avoided because undo close tab happens to separate them).
While this is a problem worth addressing, I don't think it should block (at least not any more than a number of other blocker requests that were recently turned down).
(In reply to comment #8)
> The core of the problem is that we don't have a good way to undo the action
> "close other tabs."  That is what we really need to address, even if we shuffle
> the order of undo, people are still going to accidentally hit close other tabs
> when they intended to hit the command next to it (at the moment this is only
> avoided because undo close tab happens to separate them).

Undo is not a panacea. In this case it means restoring N tabs when the user meant to initially just re-open one. That's *if* it occurs to the user to check for an undo option.

IMO, the psycho-trauma of watching all your tabs disappear is bad enough for us to address the reason why the user clicks on the wrong item in the first place.

What if we put the "close" items adjacent to each other on the current context menu, and put a separator between them and the undo item?
Could a warning dialog be used?  Like when you initiate opening a large number of tabs you are asked do you really want to open all of those tabs?  That has saved me a few times.
>bad enough for us to address the reason why the user clicks on the wrong item in >the first place.

It's too bad we don't have usage metrics for our context menus yet.  If undo close tab is the most used command, then it's going to cause some misclicks on the surrounding ones.  Simply adding extra separators and breaking the semantic grouping the sake of creating more of a buffer is too much of a hack.  But independently of this bug I've been thinking that we should group actions that apply to a larger set of tabs into the same section (instead of breaking them apart throughout the menu).  So what if we went with:


Reload Tab
---------------
Pin as App Tab
Move to Group >
Move to New Window
---------------
Reload All Tabs
Bookmark All Tabs
Close other Tabs
---------------
Undo Close
Close Other Tabs
Also a consideration is that when we later have multiple tab selection (OMGFRYN) we'll want to have a completely different context menu that only contains options that can be performed on the selected set:

Move to Group >
Move to New Window
---------------
Reload Selected Tabs
Bookmark Selected Tabs
Close Selected Tabs

so building that smaller menu allows us to keep things in the same general placement, without displaying a menu where every other item is disabled.
Filed follow up bug 609628 on supporting undo for the multiple tab closures.
(In reply to comment #12)
> Reload Tab
> ---------------
> Pin as App Tab
> Move to Group >
> Move to New Window
> ---------------
> Reload All Tabs
> Bookmark All Tabs
> Close other Tabs
> ---------------
> Undo Close
> Close Other Tabs

I'll roll up a patch with this change. Removing uiwanted.
Assignee: nobody → fryn
Status: REOPENED → ASSIGNED
Keywords: uiwanted
OS: Windows XP → All
Hardware: x86 → All
See Also: → 582993
Attached patch patchSplinter Review
The tab context menu now looks like:

/-----------------------\
|  Reload Tab           |
|-----------------------|
|  Pin as App Tab       |
|  Move to Group      > |
|  Move to New Window   |
|-----------------------|
|  Reload All Tabs      |
|  Bookmark All Tabs…   |
|  Close Other Tabs     |
|-----------------------|
|  Undo Close Tab       |
|  Close Tab            |
\-----------------------/
Attachment #489354 - Flags: ui-review?(faaborg)
Attachment #489354 - Flags: review?(dao)
Attachment #489354 - Flags: ui-review?(faaborg) → ui-review+
Attachment #489354 - Flags: review?(dao) → review+
Pushed.

http://hg.mozilla.org/mozilla-central/rev/d293acc7a273
Status: ASSIGNED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101114 Firefox/4.0b8pre

Also updated the Litmus test:
https://litmus.mozilla.org/show_test.cgi?id=10010
Status: RESOLVED → VERIFIED
Flags: in-litmus+
Target Milestone: --- → Firefox 4.0b8
Reload/Bookmark All Tabs would be better to move to List All Tabs menu. See bug 612228.
You need to log in before you can comment on or make changes to this bug.