Closed Bug 582943 Opened 9 years ago Closed 8 years ago

Replace obsolete nsHashtable with nsDataHashtable

Categories

(Directory :: LDAP XPCOM SDK, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 590494

People

(Reporter: jhorak, Unassigned)

Details

We are unable to build 'directory' folder with xulrunner right now because it use nsHashtable.h which include a nsString.h. The nsString.h is is containing nsString_internal which is incompatible with frozen linkage.
No longer blocks: mailnews-libxul
Blocks: 306324
Component: General → LDAP XPCOM SDK
Product: Thunderbird → Directory
QA Contact: general → xpcom
Version: Trunk → other
Blocks: 590494
Is this still a problem?
This was fixed as part of bug 590494.

http://mxr.mozilla.org/seamonkey/search?string=nsHashtable&case=1&find=%2Fldap%2Fxpcom%2F
"No results found"
No longer blocks: 590494
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590494
No longer blocks: 306324
You need to log in before you can comment on or make changes to this bug.