Closed Bug 583255 Opened 10 years ago Closed 10 years ago

Selection error in XUL trees in Panels with titlebar="normal"

Categories

(Core :: Widget, defect)

defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: rcampbell, Assigned: enndeakin)

References

Details

(Whiteboard: inspector)

Attachments

(1 file, 1 obsolete file)

Steps to reproduce:

1. In today's build (2010-07-30), open the Inspector (cmd-shift-I)
2. highlight and click on an area in the page to lock the inspector
3. select another node in the tree panel

You'd expect the node you clicked on to be selected, but I'm seeing the row below it selected. The selection coordinates appear to be offset by the height of the titlebar.

I'm not seeing this in the style panel which uses a XUL list.
Whiteboard: inspector
note, that I am seeing this on OS X, need to test other platforms as well.
Attached patch basic patch (obsolete) — Splinter Review
It seems that AdjustClientCoordsToBoxCoordSpace doesn't need to be so complicated or involve views at all.

I will make a test for this.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Just checked on Windows and I'm seeing the same offset error there as well. Again, lists are fine, it's just the tree that seems off.

thanks!
OS: Mac OS X → All
Hardware: x86 → All
Duplicate of this bug: 583988
Attached patch include a testSplinter Review
Attachment #461647 - Attachment is obsolete: true
Attachment #462888 - Flags: review?(roc)
Attachment #462888 - Flags: approval2.0?
Attachment #462888 - Flags: approval2.0? → approval2.0+
http://hg.mozilla.org/mozilla-central/rev/28ce6a3df8de
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
tested and works fine in this morning's build. Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.