Closed Bug 583356 Opened 12 years ago Closed 12 years ago

[10.5][Mac] No context menu available using Flash Version: 10.1.53.64 using Intel Mac, shows with PPC Mac

Categories

(Core :: Plug-ins, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta4+

People

(Reporter: marcia, Assigned: BenWa)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 571135#c14 I noted that the context menu is not showing on Intel using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b3pre) Gecko/20100730 Minefield/4.0b3pre.

STR:
1. Load youtube.com on an Intel Mac
2. Try to context click to bring up the Flash menu using Flash Version: 10.1.53.64
3. Nothing happens.

Perform the same set of STR using the same nightly build on a PPC mac and I see the context menu.
WFM, 10.1.53.64 on MacOS 10.5 x86 using a recent nightly.
I see the following errors in the Console - my profile has no extensions installed.

7/30/10 2:51:27 PM [0x0-0x6d06d].org.mozilla.minefield 2010-07-30 14:51:27.360 firefox-bin[1225:10b] *** Assertion failure in +[NSEvent mouseEventWithType:location:modifierFlags:timestamp:windowNumber:context:eventNumber:clickCount:pressure:], /SourceCache/AppKit/AppKit-949.54/AppKit.subproj/NSEvent.m:305 
7/30/10 2:51:27 PM [0x0-0x6d06d].org.mozilla.minefield 2010-07-30 14:51:27.360 firefox-bin[1225:10b] Mozilla has caught an Obj-C exception [NSInternalInconsistencyException: Invalid parameter not satisfying: NSEventMaskFromType(type) & (MouseMask|NSMouseMovedMask)] 
7/30/10 2:51:27 PM [0x0-0x6d06d].org.mozilla.minefield 2010-07-30 14:51:27.589 firefox-bin[1225:10b] *** Assertion failure in +[NSEvent mouseEventWithType:location:modifierFlags:timestamp:windowNumber:context:eventNumber:clickCount:pressure:], /SourceCache/AppKit/AppKit-949.54/AppKit.subproj/NSEvent.m:305
blocking2.0: --- → ?
Assignee: nobody → b56girard
Reproducible on 10.6 with OOPP disabled since the error is coming from the in-process implementation of ContextMenu.

Error source:
http://mxr.mozilla.org/mozilla-central/source/layout/generic/nsPluginUtilsOSX.mm#141
Status: NEW → ASSIGNED
The assertions are the same as Bug 561477.
Depends on: 561477
Attached patch Tentative Fix (obsolete) — Splinter Review
Removing these 2 lines fixes the problem with me. Is there a reason why we don't want to always generated the menu using a right click event? It appears to be less error prone.
Attachment #462170 - Flags: review?(joshmoz)
Comment on attachment 462170 [details] [diff] [review]
Tentative Fix

I don't like it but I don't know how else to satisfy the requirements for "mouseEventWithType:...". Lets try it.
Attachment #462170 - Flags: review?(joshmoz) → review+
blocking2.0: ? → beta4+
Attached patch Added summarySplinter Review
Attachment #462170 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.