If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Need notification for when Firefox version of Sync is outdated

RESOLVED FIXED

Status

Cloud Services
Firefox Sync: UI
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: zpao, Assigned: philikon)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Came up in review of Sync UI since I removed the checks the extension performed. See bug 571897 comment 46 & 48
(Assignee)

Updated

7 years ago
Component: General → Firefox Sync: UI
OS: Mac OS X → All
Product: Firefox → Mozilla Services
QA Contact: general → sync-ui
Hardware: x86 → All
Whiteboard: [sync-ui-followup]
Version: Trunk → unspecified
(Assignee)

Updated

7 years ago
Blocks: 592375
blocking2.0: --- → ?
We need to get to a resolution on this very quickly, as it involves new UI/strings.  Fortunately, new-notifications landed, so we have room to play.
blocking2.0: ? → beta7+
We still have the strings in services/sync from the addon:

error.sync.needUpdate.description = You need to update Firefox Sync to continue syncing your data.
error.sync.needUpdate.label = Update Firefox Sync
error.sync.needUpdate.accesskey = U

I think these are fine for the notification, we just want the button to do something different. In the add-on it opens the Addons Manager. In the integrated UI we might want it to open a page that explains that you want to install the Firefox Sync add-on to make your integrated Sync work again.
Yeah, that works.  It might be a "install this addon or this version of Firefox" answer, and that'll change in various ways with different contexts.  Can we get that in place, and point to a placeholder for now, and we'll sort out correct links later?
WFM!
Assignee: nobody → philipp
Created attachment 477966 [details] [diff] [review]
v1
Attachment #477966 - Flags: review?(mconnor)
Created attachment 477967 [details]
screenshot
Comment on attachment 477966 [details] [diff] [review]
v1

I think this can be priority_info, actually.

Can we link to smc instead here?  This'll eventually be a SUMO link, like the other one, and putting something on mozilla.com as a placeholder feels wrong.
Attachment #477966 - Flags: review?(mconnor) → review+

Updated

7 years ago
Summary: What happens when Firefox version of Sync is outdated → Need notification for when Firefox version of Sync is outdated
Whiteboard: [needs final patch][has review]
Created attachment 478010 [details] [diff] [review]
v1.1 for check in

Changed URL to https://services.mozilla.com/update/
(In reply to comment #7)
> I think this can be priority_info, actually.

Forgot to address this comment...

This code is pretty much straight from the add-on (minus opening the Addon Manager). It also feels more than an info since it requires user interaction.
Created attachment 478025 [details] [diff] [review]
v1.1 for check in

Bah, uploaded wrong file before. This has the new URL in it.
Attachment #478010 - Attachment is obsolete: true
http://hg.mozilla.org/mozilla-central/rev/044c9998d47f
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Whiteboard: [needs final patch][has review]
(Assignee)

Updated

7 years ago
Depends on: 599423
Blocks: 576970

Comment 12

7 years ago
also - isn't this not quite right when sync is native in firefox/fennec?  I.e. message should be "you need to update firefox to continue sync'ing"?  Seems we could have a link to a support article with more details also around storage versions...
We need to revisit strings here, the initial message is really hard because under some circumstances a user might install an add-on with a higher version than Firefox, which is why the important part is the more info link, since there's a few possibilities, all too complicated to explain in a one-line notification.
I'd like to verify this bug, however, I need to get the browser to think it's got an incompatible version with sync with the sync server.  Is there an about:config I can set to get it to think that?

Thanks!

Updated

7 years ago
Whiteboard: [qa+]
(Assignee)

Updated

7 years ago
Duplicate of this bug: 602576
(Assignee)

Updated

7 years ago
Duplicate of this bug: 603897

Updated

6 years ago
Whiteboard: [qa+]
You need to log in before you can comment on or make changes to this bug.