Omnibus ad-blocking bug for August 2010

RESOLVED FIXED

Status

Camino Graveyard
Annoyance Blocking
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

unspecified
All
Mac OS X

Details

(Whiteboard: [camino-2.0.5])

Attachments

(1 attachment)

<insert pithy saying here>

Comment 1

7 years ago
Another tracker .swf:
http://www3-cdn.effectivemeasure.net/v3/em.swf

(and also www5.effectivemeasure.net/v3/em.swf)

seen on individual articles on http://gulfnews.com/
http://gulfnews.com/news/gulf/uae/crime/no-us-help-requested-in-al-mabhouh-case-police-1.591193
For whatever reason, these don't always stick around on a reload, but on http://twitpic.com/2bp8lt

<div id="view-photo-ad"><iframe src="http://twitpic.com/ad_box.html">

Comment 3

7 years ago
I sometime see an ad on this page : http://www.leconjugueur.com/
iframe[src*="tracking.drive2media.com"] will block it.

Comment 4

7 years ago
And I still see huge ads on Newgrounds.
They can be blocked using object[data*="server.cpmstar.com"], as suggested in bug 557471.
By the way, div[class="popadtext"] blocks the text ads under each game.
On http://news.discovery.com/animals/oyster-herpes-deaths-tied-to-global-warming.html there are some Google ads that I'm not really sure we can zap by id:

div[id="google-afc-region-one"]
As a follow-up to bug 580256:

[02:00am] ardissone: hmm
[02:01am] ardissone: did we try blocking the AdBriteIntermissionAdIframe iframe?
[02:02am] ardissone: from my generated source (which I can't get working now), it looks like that's the actual "ad content"
[02:02am] phiw: I don't think so.
[02:03am] ardissone: so even if we only block it (and leave the "this is an ad" stuff), it would be a better experience
[02:03am] ardissone: unless we're already blocking it…

Comment 7

7 years ago
Ad-block seem to prevent VGTV movies from loading.
Example: http://www.vgtv.no/?id=31738

Not reproducible every time, but reload a couple of times if needed.

Comment 8

7 years ago
(In reply to comment #7)
> Ad-block seem to prevent VGTV movies from loading.
> Example: http://www.vgtv.no/?id=31738

The video is loaded inside an iframe (I guess to glue together the video ads)
<iframe width="754" height="475" frameborder="0" scrolling="no" src="http://www.vgtv.no/api/?do=iframe&amp;id=31738&amp;width=754&amp;height=475&amp;videobefore=31280&amp;beforeurl=http%3A//ads.vg.basefarm.com/RealMedia/ads/click_lx.ads/www.vg.no/video/nyheter/84140043/x41/OasDefault/vg_aha_vgtv_200710/aha_video.html/63626235333966653463376166323530&amp;videoafter=31280&amp;afterurl=http%3A//ads.vg.basefarm.com/RealMedia/ads/click_lx.ads/www.vg.no/video/nyheter/84140043/x41/OasDefault/vg_aha_vgtv_200710/aha_video.html/63626235333966653463376166323530" style="border-top-width: 0px; border-right-width: 0px; border-bottom-width: 0px; border-left-width: 0px; border-style: initial; border-color: initial; padding-top: 0px; padding-right: 0px; padding-bottom: 0px; padding-left: 0px; "></iframe>

blocked by:
iframe[src*="/ads."]
iframe[src*="/ads/"]
iframe[src*="/RealMedia/ads/

note the 'afterurl' and 'beforeurl'
Flags: camino2.0.5?
Created attachment 476609 [details] [diff] [review]
August omnibus ads

(In reply to comment #1)
> Another tracker .swf:
> http://www3-cdn.effectivemeasure.net/v3/em.swf
> 
> (and also www5.effectivemeasure.net/v3/em.swf)

Ultimately philippe and I couldn't get the actual code for that swf, since it only appeared for philippe when Flashblock was on (never for me at all), and when it wasn't blocked by Flashblock, it didn't get inserted into the page!? :P  philippe decided that's one for script-blocking to handle.

(In reply to comment #3)
> I sometime see an ad on this page : http://www.leconjugueur.com/
> iframe[src*="tracking.drive2media.com"] will block it.

We never saw this, but stuck the rule in anyway (that's an ad network).

(In reply to comment #4)
> And I still see huge ads on Newgrounds.
> They can be blocked using object[data*="server.cpmstar.com"], as suggested in
> bug 557471.

Never managed to see that this time around, either, but put in a rule for it nonetheless.

(In reply to comment #6)
> As a follow-up to bug 580256:
> 
> [02:01am] ardissone: did we try blocking the AdBriteIntermissionAdIframe
> iframe?
> [02:02am] ardissone: from my generated source (which I can't get working now),
> it looks like that's the actual "ad content"

Blocking that works nicely; the ad part of the unblockable overlay gets blocked, so the experience is better.

(In reply to comment #7)
> Ad-block seem to prevent VGTV movies from loading.
> Example: http://www.vgtv.no/?id=31738
> 
> Not reproducible every time, but reload a couple of times if needed.

There's no good, generic way to unblock those movies; Kai, your best bet is to make an @-moz-document exception in your own stylesheet.

philippe also pointed out some unblockable ads on The Independent, and while those were not blockable, I got those annoying Kontera hover ads again (Flash this time!), so we added an additional rule to block this version of them:

div[id^="kona_"]

http://www.independent.co.uk/news/world/africa/nefertiti-recipient-of-the-worlds-first-successful-facelift-2083297.html

(We were reluctant to use just "kona" for fear of catching something else, so we kept the existing rule and added the new one.)
Assignee: nobody → alqahira
Status: NEW → ASSIGNED
Attachment #476609 - Flags: superreview?(stuart.morgan+bugzilla)
(In reply to comment #9)
> (In reply to comment #7)
> > Ad-block seem to prevent VGTV movies from loading.
> > Example: http://www.vgtv.no/?id=31738

> 
> There's no good, generic way to unblock those movies; Kai, your best bet is to
> make an @-moz-document exception in your own stylesheet.

@-moz-document domain(vgtv.no) {
iframe[src*="/ads."],
iframe[src*="/ads/"],
iframe[src*="/RealMedia/ads/"] {display:inline !important;}
}

works fine.

Comment 11

7 years ago
Comment on attachment 476609 [details] [diff] [review]
August omnibus ads

sr=smorgan
Attachment #476609 - Flags: superreview?(stuart.morgan+bugzilla) → superreview+
http://hg.mozilla.org/camino/rev/68121a1c9df9
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Flags: camino2.0.5? → camino2.0.5+
CAMINO_2_0_BRANCH for 2.0.5.
Whiteboard: [camino-2.0.5]
You need to log in before you can comment on or make changes to this bug.