Closed Bug 583727 Opened 10 years ago Closed 9 years ago

DOMCI_CASTABLE_INTERFACE: macro redefinition

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla2.0b12

People

(Reporter: timeless, Assigned: timeless)

References

Details

Attachments

(1 file, 1 obsolete file)

1.27 KB, patch
peterv
: review+
Details | Diff | Splinter Review
js\src\xpconnect\src\nsDOMQS.h(80) :
warning C4005: 'DOMCI_CASTABLE_INTERFACE' : macro redefinition
nsDOMClassInfoID.h(143) : see previous definition of 'DOMCI_CASTABLE_INTERFACE'
Blocks: 533637
Attached patch bad (obsolete) — Splinter Review
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #462061 - Flags: review?(peterv)
Duplicate of this bug: 581984
Comment on attachment 462061 [details] [diff] [review]
bad

Ok, this doesn't work. so... which version is expected to win?
Attachment #462061 - Attachment description: proposal → bad
Attachment #462061 - Flags: review?(peterv) → review-
Attached patch simplerSplinter Review
Attachment #462061 - Attachment is obsolete: true
Attachment #463370 - Flags: review?(peterv)
Attachment #463370 - Flags: review?(peterv) → review+
Attachment #463370 - Flags: approval2.0?
Attachment #463370 - Flags: approval2.0? → approval2.0+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/bff2cdc499f6
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b12
Comment on attachment 463370 [details] [diff] [review]
simpler

>+#undef DOMCI_CASTABLE_INTERFACE
> #define DOMCI_CASTABLE_INTERFACES(_extra)                                     \

This seems fishy.  One ends with S and the other doesn't.

>diff --git a/js/src/xpconnect/src/nsDOMQS.h b/js/src/xpconnect/src/nsDOMQS.h

This chunk is no longer needed; the undef is present on mozilla-central.
I backed this patch as part of this pushlog <http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=7e12e3e16e6c> because of the oranges it caused <http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296852850.1296854923.2345.gz&fulltext=1>.

I'm not sure which one of the bugs was at fault, so I just backed them all out.  The assignee needs to investigate and make sure that his patch has not been the culprit, and then re-add checkin-needed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Relanded all but one of the patches in that push.  For this bug, that's:
http://hg.mozilla.org/mozilla-central/rev/b57004abf327
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.