The "Remove All Reports" button on about:crashes should remove pending crashes

RESOLVED FIXED in mozilla21

Status

()

RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: atb12345, Assigned: jwatt)

Tracking

unspecified
mozilla21
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

When I enter about:crashes in the Location bar, I get a list of several crash reports from over three months ago.  This list is titled "Submitted Crash Reports".  (It turns out that these reports are pending, not submitted.  See bug 512479.)  Clicking the "Remove All Reports" button clears the page and then says "No crash reports have been submitted."  I suppose that message is technically correct, but it's misleading because if I reload about:crashes all the reports I supposedly removed are displayed again.  I get the same result even if I restart Firefox and enter about:crashes again.

Further investigation found that these persistent reports are actually pending, not submitted.  I found them listed in my Application Data\Mozilla\Firefox\Crash Reports\pending folder.  The "submitted" folder is empty.  I suppose clicking "Remove All Reports" clears out only that folder.  I don't know if there's a good reason for not clearing the pending folder, especially when it's apparent these are reports that never will be automatically submitted anyway.  When I click "Remove All Reports", I expect all of the reports to be removed.  If actually removing all reports is not desired by Mozilla for some reason, then perhaps pending reports should be listed separately, not listed as "Submitted Crash Reports".  See bug 512479.

Reproducible: Always
Even if we fix bug 512479 we should still probably fix this. Thanks for the bug report!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Duplicate of this bug: 614645
Duplicate of this bug: 628308
(Assignee)

Updated

7 years ago
Summary: "Remove All Reports" doesn't remove pending crash reports in about:crashes → The "Remove All Reports" button on about:crashes should remove pending crashes
(Assignee)

Comment 4

7 years ago
Created attachment 543676 [details] [diff] [review]
patch

This depends on 'part 1' in bug 462197.
Assignee: nobody → jwatt
Status: NEW → ASSIGNED
Attachment #543676 - Flags: review?(ted.mielczarek)
(Assignee)

Comment 5

7 years ago
Tested, and works without problem for me.
Comment on attachment 543676 [details] [diff] [review]
patch

Review of attachment 543676 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine, but please add a test.
Attachment #543676 - Flags: review?(ted.mielczarek) → review+

Updated

7 years ago
Duplicate of this bug: 673520
Duplicate of this bug: 684199

Comment 9

6 years ago
This appears to be broken again in Seamonkey 2.13 20120912204827. I click the Remove All Reports button and all the previous crashes appear to be deleted. Reloading about:crashes or even exiting the browser and going to about:crashes shows all the crashes as if they were not deleted.

Comment 10

6 years ago
It's broken in FF 19.0.  I had 61,000 pending reports in  the pending folder.  About:crashes hangs with a slow script.

I would guess that submitted and pending could be listed with a flag so that chonology can be preserved and submitted and pending bugs should be removed separately.  Submitting pending reports from this page would be nice too.
This patch never landed for some reason. jwatt: did you forget about this patch?
Also, fixing bug 820823 would make this much less of an issue, since it would ensure that we don't pile up pending reports like this.
(Assignee)

Comment 13

6 years ago
Uh, yes. Can someone land it for me, since I don't have time right now.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/afc451ec7f07
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.