Dropmarkers don't appear correctly under Linux

VERIFIED FIXED in mozilla2.0b8

Status

()

defect
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: wgianopoulos, Assigned: Unfocused)

Tracking

Trunk
mozilla2.0b8
All
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments)

Posted image screenshot
The utilities menu button in the add-ons manager seems to display an unpressed and pressed button next to each other (at least under fedora 12 using gnome).

See attached screenshot.

Presumably this should look more like it does under Windows.
Blocks: 562622
blocking2.0: --- → ?
Keywords: regression
Blocks: 567127
Component: Theme → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: theme → add-ons.manager
Well, as it turns out, comparing the page between Windows an Linux, this is NOT the only Linux issue.  Everyplace where on the page in Windows there is a dropmarker, it is absent on the page under Linux.

This is with a fresh profile and default theme.

Also the sort column direction indicator is absent.
Assignee: nobody → bmcbride
blocking2.0: ? → final+
Actually yes let's just cover the button in bug 584330 and use this for the dropmarkers issue.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Keywords: regression
Summary: Utilities icon in add-ons manager does not display correctly under Linux → Dropmarkers don't appear correctly under Linux
(In reply to comment #3)
> Actually yes let's just cover the button in bug 584330 and use this for the
> dropmarkers issue.

I'm sure you meant bug 584006.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Somehow having a bug confirmed as a blocker, but the status being unconfirmed didn't make a great deal of sense.
No longer blocks: 567127
Whiteboard: [good first bug]
Posted image Fix for Linux
I was able to get it properly looking under GNU/Linux, by using multiple backgrounds instead of list-style-image. You can see the properties on the screenshot I've attached in the Firebug window.

Haven't tested in under other OSs though, because at the moment I don't have an access to any. Also, I'm not sure this is a fix to apply, more like a hack, but, whatever.
(In reply to comment #7)
> Created attachment 471467 [details]
> Fix for Linux
> 
> I was able to get it properly looking under GNU/Linux, by using multiple
> backgrounds instead of list-style-image. You can see the properties on the
> screenshot I've attached in the Firebug window.
> 
> Haven't tested in under other OSs though, because at the moment I don't have an
> access to any. Also, I'm not sure this is a fix to apply, more like a hack,
> but, whatever.

I can work that up into a patch for the gnomestripe theme.

However, it only fixes 1/2 of the issue.  The sort arrows on the Name and Last Updated column headers to show which it is sorted by and the direction of the sort do not show up either.
The patch in bug 584006 fixes it for the utilities button (although it hasn't landed yet). It does so by only setting list-style-image to the .button-icon class (which seems like a more correct fix). ie:

button .button-icon {
  list-style-image: url(...);
}

The same strategy should work for the sort buttons too.
Status: NEW → ASSIGNED
Whiteboard: [good first bug] → [needs 601022]
Fixed by bug 601022, file any remaining issues separately
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [needs 601022]
Target Milestone: --- → mozilla2.0b8
Verified fixed with Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101125 Firefox/4.0b8pre ID:20101125030318
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Flags: in-litmus-
Hardware: x86_64 → All
You need to log in before you can comment on or make changes to this bug.