Some buttons lost borders when :hover-ed (Win XP)

RESOLVED DUPLICATE of bug 589236

Status

()

Firefox
Theme
--
trivial
RESOLVED DUPLICATE of bug 589236
8 years ago
7 years ago

People

(Reporter: Please Ignore This Troll (Account Disabled), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100803 Minefield/3.7a5pre YB/3.5.1
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100803

I have 2 OS installed - Win XP and Win 7, I noticed a small bug on XP, that is not present in 7.
If you detach "open new tab" button from #tabbrowser-tabs to #TabsToolbar (e.g. move the button to the left from tabs), and then mouse over it - on Win 7 you'll see a square border, around it, which won't happen if you are on XP.
E.g. currently the :hover-ed state for such a button is the same as normal state for it, if the button is detached and if you are on XP.

Reproducible: Always

Steps to Reproduce:
0. Make sure you are using Windows XP.
1. Move "open new tab" button to the left on the tabs toolbar.
2. Mouse over it.
3. Try to find any difference between normal and :hover-ed state for this button.
Actual Results:  
No difference can be found.

Expected Results:  
The :hover-ed state should add a square border to that button, just like it is on Win 7.
Version: unspecified → Trunk
I don't know how to make a CSS-rules be OS-dependent,
I made a style:
#new-tab-button:hover, #alltabs-button:hover {
 padding-left: 2px; padding-right: 2px;
/* reducing padding by -2px in order to avoid bouncing, because borders add +2px to width for this button. Actually it is a little bit wrong, but in fact it works, and doesn't brake anything until you change the value for padding for this button by another style/theme/skin */
 border-top: 1px solid white; border-left: 1px solid white;
 border-right: 1px solid grey; border-bottom: 1px solid grey;
-moz-border-radius:0; /* on XP all borders are square */
-moz-transition-property: none; /* remove the border color transition */
}
but I don't know yet, how it will look in win 7, and if it will brake anything.
Summary: Detached "new tab" button lost it's effect when :hover-ed (XP) → Some buttons lost borders when :hover-ed (Win XP)
tested on win7: nothing is broken except the bouncing buttons' width, when they are hovered.
certainly, it is caused by
padding-left: 2px; padding-right: 2px;
but without this line - the same bouncing will be on XP, so if anyone is aware of how to add borders without making borderless element wider - the patch will be ready.
2 things I forgot:
1. XP and 7 use different skin-files, so probably, there should be no problem with fixing the bug of a skin for a single OS, without affecting another OS.
2. I totally forgot about outline function, which exactly adds a border to the element, without changing it's width, so the patch should just add these lines:

#new-tab-button:hover, #alltabs-button:hover {
 outline: 1px solid white;
-moz-border-radius:0;
-moz-transition-property: none;}

to the file corresponding to XP classic skin.
Someone, create a patch/review/review+/resolve fixed.
the first style is still better :-/

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589236
You need to log in before you can comment on or make changes to this bug.