Closed Bug 584354 Opened 12 years ago Closed 12 years ago

Assertion failure: JS_HAS_OPTION(acx, JSOPTION_UNROOTED_GLOBAL) whilst running Thunderbird message-header tests in debug mode

Categories

(Core :: XPCOM, defect)

All
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 584495

People

(Reporter: standard8, Assigned: gal)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Attached file backtrace
I'm trying to run the Thunderbird Mozmill-based message-header tests in debug mode. I'm getting:

Assertion failure: JS_HAS_OPTION(acx, JSOPTION_UNROOTED_GLOBAL), at /Users/moztest/comm/main/src/mozilla/js/src/xpconnect/src/xpcjsruntime.cpp:383

it happens on every run, but in different places, which seems to indicate it is cycle collection related.

I'm flagging this as a possible regression from bug 549806 as that is the bit that touched this code last.

Also attaching a backtrace at the point the assertion occurs.
Note: if I make the assertion into an if statement, then it all runs fine - though obviously there could be some hidden issue.
I have no idea if this is right or not, but it works around the issue - it puts back the if statement that was there before the assertion.

As other Thunderbird developers are seeing this issue I'm putting this up here as a starter for ten.
Attachment #463532 - Flags: review?(gal)
Severity: normal → critical
This needs to be fixed. Assertions are fatal, or should be, and they're treated as critical bugs anwyay (in SpiderMonkey). No fair leaving them in Gecko code to bite others.

/be
Assignee: nobody → gal
blocking2.0: --- → ?
Mark do you have a way to reproduce this?
Andreas, unfortunately the only way I've found so far is:

1) Build Thunderbird in debug mode (https://developer.mozilla.org/En/Simple_Thunderbird_build) with enable-tests

2) Have Mozmill installed: https://developer.mozilla.org/en/Thunderbird/Thunderbird_MozMill_Testing

3) Run "make SOLO_TEST=message-header mozmill-one" from objdir.

Wait for it to crash (although I've found I can hook in the debugger before the cycle collection happens).

I can try and find a simpler way next week, but I'm not confident of finding one.
I've run this a few times now with the latest tracemonkey merge and I can't get it to fail. Therefore I think this is a duplicate of bug 584495.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584495
Attachment #463532 - Attachment is obsolete: true
Attachment #463532 - Flags: review?(gal)
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.