Last Comment Bug 585141 - (mathml-screenshots) Update Screenshot pages of Mozilla MathML Project
(mathml-screenshots)
: Update Screenshot pages of Mozilla MathML Project
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Frédéric Wang (:fredw)
:
Mentors:
Depends on: 449396 mathml-href
Blocks: update-mathml-doc remove-screenshots
  Show dependency treegraph
 
Reported: 2010-08-06 12:15 PDT by Frédéric Wang (:fredw)
Modified: 2011-08-08 01:08 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Current screenshot of basics.xhtml (76.59 KB, image/png)
2010-11-23 14:23 PST, Frédéric Wang (:fredw)
no flags Details
patch href + stylistic effects (1.76 KB, patch)
2010-11-24 14:32 PST, Frédéric Wang (:fredw)
no flags Details | Diff | Splinter Review
patch href + stylistic effects (V2) (1.11 KB, patch)
2011-06-27 12:04 PDT, Frédéric Wang (:fredw)
karlt: review+
karlt: checkin+
Details | Diff | Splinter Review
Move the mathvariant attribute from mrow to math (414 bytes, patch)
2011-08-06 12:00 PDT, Frédéric Wang (:fredw)
karlt: review+
karlt: checkin+
Details | Diff | Splinter Review

Description Frédéric Wang (:fredw) 2010-08-06 12:15:58 PDT
The page has moved to MDN:
https://developer.mozilla.org/en/Mozilla_MathML_Project/Mozilla_MathML_Screenshots

but we need to update the screenshots. We should check carefully if there is no regression since the time when the screenshots were taken.
Comment 1 Frédéric Wang (:fredw) 2010-11-23 14:23:56 PST
Created attachment 492795 [details]
Current screenshot of basics.xhtml

(with the patch of bug 427990 for XLink)

Compared with
http://www-archive.mozilla.org/projects/mathml/screenshots/basics.png

it seems that it remains only one regression: font-weight=bold is not inherited on single-char <mi/>'s. I guess it is the same issue as bug 449396.
Comment 2 Karl Tomlinson (:karlt) 2010-11-23 14:36:49 PST
(In reply to comment #1)
> it seems that it remains only one regression: font-weight=bold is not inherited
> on single-char <mi/>'s.

I don't think that's a bug.  IMO the default mathvariant on identifiers should override font-weight.  i.e. style should not affect identifiers.

> I guess it is the same issue as bug 449396.

That's a little different.  mathvariant actually changes (or, in the case of mstyle with bug 449396, should change) the characters for (i.e. meaning of) the identifiers.
Comment 3 Frédéric Wang (:fredw) 2010-11-24 12:25:03 PST
OK, that makes sense. Anyway, I'm not sure that the REC describes how style should be inherited from the parent of the <math/> element... So we should rather modify basics.xhtml to use mathvariant on <math/>. Similarly, we should replace the link by the recommended href attribute for MathML linking (I believed that the page contained a xlink but actually it is a HTML <a/>).
Comment 4 Karl Tomlinson (:karlt) 2010-11-24 12:33:46 PST
Using mathvariant is not really right, because the page is trying to demonstrate "stylistic effects" available due to being in a browser, and mathvariant is not a stylistic effect.

Is there some other stylist effect that does not conflict with mathvariant but could be demonstrated instead?
Perhaps underline? or a rotation?
Comment 5 Frédéric Wang (:fredw) 2010-11-24 13:03:17 PST
OK, I see what you mean. I think underline currently adds some unwanted spaces under math frames (such that those on the link just before).
We can also simply modify the font-size.
Comment 6 Karl Tomlinson (:karlt) 2010-11-24 14:00:04 PST
font-size would be fine.
If text-shadow works, it could be a good candidate.
http://hacks.mozilla.org/2009/06/text-shadow/
Comment 7 Frédéric Wang (:fredw) 2010-11-24 14:32:27 PST
Created attachment 493120 [details] [diff] [review]
patch href + stylistic effects

text-shadow does not seem to work on the <mo/>'s.
Comment 8 Karl Tomlinson (:karlt) 2011-06-26 14:18:59 PDT
Comment on attachment 493120 [details] [diff] [review]
patch href + stylistic effects

>-<a href="http://www.geocities.com/CapeCanaveral/Launchpad/3740/">
>-<math xmlns="&mathml;">
>+<math xmlns="&mathml;" href="http://en.wikipedia.org/wiki/Cape_Canaveral">

This was a link to information on Pythagoras' Theorem.
http://web.archive.org/web/20091027040032/http://geocities.com/CapeCanaveral/Launchpad/3740/
If you can find a page on Pythagoras' Theorem, that would be better.

The rest looks good, thanks.
Comment 9 Frédéric Wang (:fredw) 2011-06-27 12:04:07 PDT
Created attachment 542223 [details] [diff] [review]
patch href + stylistic effects (V2)
Comment 10 Karl Tomlinson (:karlt) 2011-07-10 18:35:40 PDT
Comment on attachment 542223 [details] [diff] [review]
patch href + stylistic effects (V2)

http://viewvc.svn.mozilla.org/vc?view=revision&revision=92371
Comment 11 Frédéric Wang (:fredw) 2011-08-01 11:12:09 PDT
In the equation "Y = a X + b" (after "write vector equations"), the use of mathvariant on mrow is not valid.

We could use a mstyle instead, but then the <mi>'s are no longer styled italic as in the original screenshot. Using style="font-weight: bold;" does not seem to work, the default style "italic" (not bold) is applied for the <mi>'s. For the moment, I can't see another option than setting the bold-italic style on each individual mi.
Comment 12 Karl Tomlinson (:karlt) 2011-08-04 16:17:03 PDT
(In reply to comment #11)
> In the equation "Y = a X + b" (after "write vector equations"), the use of
> mathvariant on mrow is not valid.
> 
> We could use a mstyle instead, but then the <mi>'s are no longer styled
> italic as in the original screenshot.

Putting mathvariant on the the <math> element should be valid.  (I can't remember whether or not that works.)  I thought vector identifiers were usually not italic but mathvariant="bold-italic" should work fine.

> For the moment, I can't see another option than setting the
> bold-italic style on each individual mi.

mathvariant on the <math> element would apply to the operators also, and I don't think they should be bold (even though they are in the screenshot).

So mathvariant on each individual mi is probably appropriate.
Comment 13 Karl Tomlinson (:karlt) 2011-08-04 16:19:37 PDT
(In reply to comment #12)
> mathvariant on the <math> element would apply to the operators also, and I
> don't think they should be bold (even though they are in the screenshot).

Oh, actually, there may be no bold variants of + and =, and so mathvariant on <math> might do the right thing.
Comment 14 Frédéric Wang (:fredw) 2011-08-06 12:00:57 PDT
Created attachment 551269 [details] [diff] [review]
Move the mathvariant attribute from mrow to math

Let's make <mi>'s representing vector "bold".
Comment 15 Karl Tomlinson (:karlt) 2011-08-07 22:50:42 PDT
Comment on attachment 551269 [details] [diff] [review]
Move the mathvariant attribute from mrow to math

http://viewvc.svn.mozilla.org/vc?view=revision&revision=93440
Comment 16 Frédéric Wang (:fredw) 2011-08-08 01:08:49 PDT
All the screenshots at

https://developer.mozilla.org/en/Mozilla_MathML_Project/Screenshots

are now updated, except the one for Emails.

Note You need to log in before you can comment on or make changes to this bug.