All other open pages freeze while one page loads

RESOLVED DUPLICATE of bug 516752

Status

()

RESOLVED DUPLICATE of bug 516752
9 years ago
9 years ago

People

(Reporter: thezone, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

Many, many times throughout the day, Firefox will completely freeze all open pages/tabs wile a new page loads.  It will not become responsive until said page is resolved.

New pages with a lot of graphics, some flash ads or 'click/googleanylitics' type connections are made.

It's fine that the NEW page hangs while this stuff is loading, but all other open tabbed pages ALSO freeze while the offending page resolves.  This results in many seconds of clicking tab pages trying to do something else while the offending page loads.

Happens with FF versions as far back as I can remember.

Reproducible: Always

Steps to Reproduce:
1.Have 5 or so tabs open as a start.
2.Hit a random web page with offending objects or calls.
Actual Results:  
ALL tab pages freeze while offending page tries to load.

Expected Results:  
ALL other tab pages should operate and be responsive while the offending page loads: however long that takes.

ALL other tab pages should operate and be responsive while the offending page loads: however long that takes.
Component: Tabbed Browser → General
Product: Firefox → Core
QA Contact: tabbed.browser → general
Since this is phrased to be a general "one tab shouldn't affect other tabs" bug, I'll mark this as a duplicate of "electrolysis" project that aims to run tabs rendering in different processes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 516752
You need to log in before you can comment on or make changes to this bug.