Closed Bug 585414 Opened 10 years ago Closed 8 years ago

warning: 'main' is usually a function in jpeg/jcmainct.c

Categories

(Core :: ImageLib, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 666621

People

(Reporter: timeless, Assigned: timeless)

References

(Blocks 1 open bug)

Details

(Whiteboard: [build_warning])

Attachments

(1 file)

this has bugged me for ages.

jpeg/jcmainct.c:
 In function ‘start_pass_main’:
71: warning: ‘main’ is usually a function
 In function ‘process_data_simple_main’:
117: warning: ‘main’ is usually a function
 In function ‘jinit_c_main_controller’:
247: warning: ‘main’ is usually a function

I know it's legal, but I'm on a crusade and we really don't need this warning.
Attached patch patchSplinter Review
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #463896 - Flags: review?(bobbyholley+bmo)
Comment on attachment 463896 [details] [diff] [review]
patch

We're about to replace libjpeg anyway, so I don't want to take this patch right now. Can you rebase/reflag after bug 573948 lands?
Attachment #463896 - Flags: review?(bobbyholley+bmo)
Whiteboard: [build_warning]
I think we have the same warning with libjpeg-turbo.  If you want to fix the warning, you'll also need to update the patch we apply to the libjpeg-turbo source.
It's a duplicate of bug 666621.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 666621
You need to log in before you can comment on or make changes to this bug.