Closed Bug 585652 Opened 10 years ago Closed 10 years ago

Get fennec to zoom and scroll correctly for Meego's overlay VKB.

Categories

(Firefox for Android Graveyard :: General, defect)

All
MeeGo
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 587492

People

(Reporter: jbos, Unassigned)

Details

Attachments

(1 file)

Meego use an overlay vkb and does not resize the browser.
This patch adds a new element for VKB handling to the browser. A preference decide if you use a overlay or a resize based VKB. The Calculation is based on that.

The patch has some areas to fix up. We need still to transfer informations about the size of the vkb, if the hardware keyboard is visible and which keyboard is visible.

What this patch does:
 - changing the calculation 
 - fixed height for characters to guaranty that the user can read what he is typing
 - scroll and zoom back to caret in case user scrolled / zoomed away and start typing again.
 - adjustment of scroll and zoom in case of rotation 
 - following the caret to keep it visible
 - adds a spacer to cover cases when the input field is on the bottom of a page
 - adds a workaround for a text render issue (text not painted on second page - tilemanager problem)
 - position and zooming correctly for non textinput fields and ensure that they are visible.
 - moves the formhelper correctly

This is still WIP, it does not cover yet:
 - UI cases
 - In case the Hardware Keyboard is visible you see the spacer
 - Static height of the spacer (worst case height)
Summary: Get Meego overlay vkb working with fennec → Get fennec to zoom and scroll correctly for Meego's overlay VKB.
Blocks: 583135
No longer blocks: 583135
Blocks: 583150
Blocks: 584225
Depends on: 585680
Meego related issue.  will revisit triage in the future
This bug got split up, there is right now no Meego Part about it.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587492
No longer blocks: 583150, 584225
No longer depends on: 585680
You need to log in before you can comment on or make changes to this bug.