autocomplete matches unrelated hosts when searching for www.example.com

RESOLVED WONTFIX

Status

()

Firefox
Address Bar
RESOLVED WONTFIX
8 years ago
4 years ago

People

(Reporter: Elmar Ludwig, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Mozilla/5.0 (X11; Linux i686; en-US; rv:2.0b2pre) Gecko/20100706 Minefield/4.0b2pre

Bug 461483 changed autocomplete behaviour so that a leading (typed) 'www.' is ignored when matching URLs in the location bar. This makes it very hard to actually match a URL starting with 'www.' when there are different hosts from the same domain in the autocomplete history. Even typing out the full host name will not restrict the results in any meaningful way.

Steps to reproduce:

1. start Firefox with a new profile
2. visit these URLs:
   - http://www.mozilla.org
   - http://wiki.mozilla.org
   - http://bugzilla.mozilla.org
   - http://litmus.mozilla.org
   - http://developer.mozilla.org
3. type 'www.moz' or 'www.mozilla.org'

Actual result: The autocomplete dropdown is filled with all the entries from *.mozilla.org, the actual host 'www.mozilla.org' is somewhere around postion 10.

Expected result: Show only results for 'www.mozilla.org'.
Duplicate of this bug: 583851

Comment 2

6 years ago
This is definitely the wrong behaviour.  Clearly I deliberately typed in "www." before some more text, and I don't expect my search tokens to be mangled before matches are arrived at.
Duplicate of this bug: 698443

Comment 4

4 years ago
Any developer comment on this? E.g. "yes, agreed, bug", "no - intended behaviour"?
(Reporter)

Comment 5

4 years ago
(In reply to mozilla from comment #4)
> Any developer comment on this? E.g. "yes, agreed, bug", "no - intended behaviour"?

Intended behaviour, at least for now - especially with inline autocomplete, which is enabled by default. I stopped caring long ago and wrote my own extension to fix this.
yes, it's intended behavior, autocomplete always ignored www on purpose, the cases where this is an issue are very limited. Morever with inline completion in most cases you don't even need to search through the popup results, so the positioning there is not relevant.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.