Web Console input field isn't resized when the user presses Return

RESOLVED INVALID

Status

()

Firefox
Developer Tools
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: pcwalton, Assigned: pcwalton)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kd4b5] [patchclean:0817])

Attachments

(2 attachments)

(Assignee)

Description

7 years ago
Created attachment 464657 [details] [diff] [review]
Proposed patch.

When the user presses Return to submit a long line of JavaScript, the Web Console field isn't resized. This problem also occurs on other events that change the value of that field without triggering key presses (undo, for example).

The attached patch fixes this.

Requesting blocking status for Firefox 4 because this is a serious UI issue with the Console.
Attachment #464657 - Flags: feedback?
(Assignee)

Updated

7 years ago
blocking2.0: --- → ?

Comment 1

7 years ago
Please set the feedback flag with a bugzilla id:)

Updated

7 years ago
Attachment #464657 - Flags: feedback? → feedback?(jviereck)

Comment 2

7 years ago
Comment on attachment 464657 [details] [diff] [review]
Proposed patch.

>+  /**
>+   * Sets the value of the input field (command line), and resizes the field to
>+   * fit its contents. This method is preferred over settings "inputNode.value"
>+   * directly, because it correctly resizes the field.
>+   *
>+   * @param string newValue
>+   *        The new value to set.
>+   * @returns void
>+   */
>+  setInputValue: function JST_setInputValue(newValue)
>+  {
>+    this.inputNode.value = newValue;
>+    this.resizeInput();
>+  },
>+

Use aNewValue as argument variable. Otherwise f+!
Attachment #464657 - Flags: feedback?(jviereck) → feedback+
(Assignee)

Comment 3

7 years ago
Created attachment 466720 [details] [diff] [review]
Proposed patch (revised per feedback).

Patch revised per feedback.
Attachment #466720 - Flags: review?(dietrich)
Attachment #466720 - Flags: review?(dietrich) → review+

Comment 4

7 years ago
Comment on attachment 466720 [details] [diff] [review]
Proposed patch (revised per feedback).

Requesting approval to land this in Firefox 4.
Attachment #466720 - Flags: approval2.0?

Updated

7 years ago
Attachment #466720 - Flags: approval2.0? → approval2.0+

Updated

7 years ago
Keywords: checkin-needed

Updated

7 years ago
Whiteboard: [kd4b5] [patchclean:0817]
(Assignee)

Comment 5

7 years ago
The Web Console doesn't actually resize anymore due to a regression, so this bug is no longer applicable.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Assignee)

Updated

7 years ago
Depends on: 588967

Updated

7 years ago
Keywords: checkin-needed

Comment 6

7 years ago
(In reply to comment #5)
> The Web Console doesn't actually resize anymore due to a regression, so this
> bug is no longer applicable.

will it be reopened after the regression is fixed?
(Assignee)

Comment 7

7 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > The Web Console doesn't actually resize anymore due to a regression, so this
> > bug is no longer applicable.
> 
> will it be reopened after the regression is fixed?

Presumably the patch that fixes the regression will fix this one as well :)
Canceling blocking per comment #5.
blocking2.0: ? → ---
Blocking request, that is.

Updated

7 years ago
No longer depends on: 588967
You need to log in before you can comment on or make changes to this bug.