If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.
Bug 559481 (consoleui)

[meta] DevTools Console front end implementation

RESOLVED DUPLICATE of bug 704110

Status

()

Firefox
Developer Tools: Console
--
major
RESOLVED DUPLICATE of bug 704110
8 years ago
6 years ago

People

(Reporter: ddahl, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
We are shooting for a beta-quality release on Trunk in Q2. Need some face time with UX, also filing a UI "mockups" bug.

I have begun working on the UI, but only enough to make things work. I think it is sparse enough for now that any functionality is not going to be too hampered by a radical design:)

try builds will be posted each week.
(Reporter)

Updated

8 years ago
Blocks: 559482
(Reporter)

Updated

8 years ago
Blocks: 534398
(Reporter)

Updated

8 years ago
Depends on: 554937
(Reporter)

Comment 1

8 years ago
(In reply to comment #0)
> We are shooting for a beta-quality release on Trunk in Q2. Need some face time
> with UX, also filing a UI "mockups" bug.
After meeting with UX and discussing all of this with Johnath, Robcee, et al. It looks like we are still going for alpha-quality push to trunk in Q2
(Reporter)

Comment 2

8 years ago
A meeting with limi has set the direction for this implementation:

1. a developer menu item in the UI exposes a button that shows an "Arrow Panel" with the console log running.

2. a user can select "open console in new window", "open console in tab" and "dismiss".

also:

We need a "filter toolbar". with toggle buttons for each tab to toggle event listeners, network logging, css parser logging, etc... We should use text-based buttons. Not icons.
(In reply to comment #1)
> (In reply to comment #0)
> > We are shooting for a beta-quality release on Trunk in Q2. Need some face time
> > with UX, also filing a UI "mockups" bug.
> After meeting with UX and discussing all of this with Johnath, Robcee, et al.
> It looks like we are still going for alpha-quality push to trunk in Q2

To be clear, here - I think we should push alpha quality asap, but still work to a goal of beta quality in Q2. Land early, land often.
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> to be clear, here - I think we should push alpha quality asap, but still work
> to a goal of beta quality in Q2. Land early, land often.

indeed. just being conservative here - i know the review process will be long.
(Reporter)

Updated

7 years ago
OS: Linux → All
(Reporter)

Updated

7 years ago
No longer blocks: 534398
do we really need arrow panels for this? Why not a regular panel with a titlebar as the Inspector is going to have? See bug 552982.
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> do we really need arrow panels for this? Why not a regular panel with a
> titlebar as the Inspector is going to have? See bug 552982.

No, we don't need arrow panels. This was some preliminary ideas, that's all. It would be better if the Inspector and Console matched look and feel.
Taking this. Proposed mockup to be submitted for UX review to be attached.
Assignee: ddahl → pwalton
Status: NEW → ASSIGNED
Created attachment 457907 [details]
Console mockup 1. Not yet UX reviewed.
blocking2.0: --- → ?
Depends on: 580400
Depends on: 578658
Depends on: 580502
Rationale for blocking request: The console UI that is currently shipping as part of the beta has not been reviewed by the UX team and was never intended to be anything more than a placeholder. As these tools are new parts of Firefox 4 and on the roadmap, they should have a proper UI designed and implemented.
Depends on: 580820
Depends on: 580854
Created attachment 459274 [details]
Mockup 3.

Attaching a third mockup (the second was not posted to this bug, sorry). Certain parts of it are highly subject to change:

(1) All icons will quite possibly be replaced by text, subject to graphic design bandwidth and platform constraints.
(2) The style of the filter bar has not yet been fully hashed out. limi raised some concerns with the design in the mockup; it is likely that it will first be a series of checkboxes.
Attachment #457907 - Attachment is obsolete: true
(Reporter)

Comment 11

7 years ago
(In reply to comment #10)
> Created attachment 459274 [details]
> Mockup 3.
> 
> Attaching a third mockup (the second was not posted to this bug, sorry).
> Certain parts of it are highly subject to change:
> 
> (1) All icons will quite possibly be replaced by text, subject to graphic
> design bandwidth and platform constraints.
> (2) The style of the filter bar has not yet been fully hashed out. limi raised
> some concerns with the design in the mockup; it is likely that it will first be
> a series of checkboxes.

regardless, this mockup is great. The direction is looking up.
(Reporter)

Updated

7 years ago
No longer depends on: 554937
(Reporter)

Comment 12

7 years ago
I removed the arrow panels bug as a blocker here until all of the real mockups and concepts come in for the console UI. I don't think it is worth it to block on it.
Depends on: 581183
Depends on: 581231
No longer depends on: 578658
See Also: → bug 578658
Depends on: 581241

Comment 13

7 years ago
Are we going to add UI for controlling the DOM mutation event logging? see bug 575791
(In reply to comment #13)
> Are we going to add UI for controlling the DOM mutation event logging? see bug
> 575791

As far as I know the DOM Mutation events are gone.
Keywords: uiwanted
Depends on: 579412
Depends on: 582135, 582121
Depends on: 582400
Depends on: 582455
Depends on: 582460
Depends on: 583145
Depends on: 583349
This is basically a meta-bug. Please request blocking on the individual bugs where change will actually occur.

Also, should get a UX review on these proposed changes as soon as possible.
blocking2.0: ? → ---
Hardware: x86 → All
Summary: DevTools Console front end implementation → [meta] DevTools Console front end implementation

Updated

7 years ago
Whiteboard: [kd4b5]
Depends on: 585195
Depends on: 585237

Updated

7 years ago
Depends on: 585530
Depends on: 586125
Depends on: 586135
Depends on: 586142
Depends on: 586724
Depends on: 573840
Depends on: 586388

Updated

7 years ago
Whiteboard: [kd4b5]

Updated

7 years ago
Depends on: 593956
Depends on: 596315
Alias: consoleui
Depends on: 596822
Depends on: 597460
Depends on: 597502
Depends on: 599240
Depends on: 601183

Updated

7 years ago
Depends on: 601464

Updated

7 years ago
Assignee: pwalton → nobody
Assignee: nobody → shorlander
Keywords: uiwanted

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 704110

Updated

6 years ago
Assignee: shorlander → nobody
Component: Developer Tools → Developer Tools: Console
QA Contact: developer.tools → developer.tools.console
You need to log in before you can comment on or make changes to this bug.