Closed Bug 586460 Opened 9 years ago Closed 7 years ago

File all reftest failures and crashes from running reftests with accelerated layers on Windows 7

Categories

(Core :: Graphics, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: joe, Assigned: cbook)

References

Details

We need to have all the crashes and reftest failures from running with hardware-accelerated layers filed as bugs. Crashes should block bug 581212, and reftest failures should block bug 586459.

In order to run with accelerated layers, do this in your shell:
 $ export MOZ_ACCELERATED=11
 $ cd (wherever your object directory is)
 $ make reftest
Summary: File all reftest failures and crashes from running reftests with MOZ_ACCELERATED=1 on Windows 7 → File all reftest failures and crashes from running reftests with accelerated layers on Windows 7
So, my suggestion here is to make sure reftest-sanity works first, figure those out. Then proceed filing stuff. As this is quite untested in the new D3D9 setting it's not unlikely pretty much every reftest fails. Let's get sanity in a good state. Then proceed, otherwise we'll likely be wasting a lot of time on reftest failures all caused by a more fundamental problem in reftests+D3D9. Or we'll be assuming reftests pass just because they do an == and both the reference and the test is completely empty and broken :-).
Assignee: nobody → cbook
I believe that all the reftest failures for D3D9 are now filed (and fixed!!) Thanks Tomcat!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
(In reply to comment #2)
> I believe that all the reftest failures for D3D9 are now filed (and fixed!!)
> Thanks Tomcat!

just found Bug 593854 as new unexpected fail (also note that Bug 590731, Bug 590732, Bug 590734 and Bug 590733 still fail)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 9 years ago7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.