Possible 3.6.9 binary compatibility regression with IcedTeaPlugin.so

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: christian, Unassigned)

Tracking

({crash, regression})

1.9.2 Branch
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Filing this because it looks odd and needs more investigation...

Looking at the graph in http://crash-stats.mozilla.com/products/Firefox/versions/3.6.9pre?duration=14 and http://crash-stats.mozilla.com/daily?p=Firefox&v[]=3.6.9pre, there looks to be a bit of a crash spike around the 4th. I'm not sure if the numbers are statistically significant, though rapid increase followed by leveling at a higher rate generally is what we see with regressions.

Nothing really jumps out at me in http://crash-stats.mozilla.com/topcrasher/byversion/Firefox/3.6.9pre, except that IcedTeaPlugin.so on linux shows up twice in the top 10, which seems odd.

Looking at http://crash-stats.mozilla.com/query/query?product=Firefox&version=ALL%3AALL&range_value=1&range_unit=weeks&date=08%2F11%2F2010+19%3A00%3A34&query_search=signature&query_type=startswith&query=IcedTeaPlugin.so&build_id=&process_type=any&hang_type=any&do_query=1 , crashes in IcedTeaplugin.so have been seen before, but the frequency looks to have increased >10x in 3.6.9pre.

For example, IcedTeaPlugin.so@0x873c was reported on 3.6.7 (2 crashes) and 3.6.8 (6 crashes), but the numbers are minuscule compared to 3.6.9pre (>30 crashes) and 4.0. I would expect released versions to be much higher as the ADUs are higher.

For IcedTeaPlugin.so@0x873c in particular, it looks like the signature started in 3.6.9pre on build 20100805, which points to something changing around 2010-08-04 or so. It showed up first on 4.0 on 2010-07-20, but I don't see any smoking guns in pushes for around those times.

IcedTeaPlugin.so@0xaa15 has only been seen in 3.6.9pre and just started showing up build 20100805 as well. This is another red flag, as if the problem was a buggy IcedTeaPlugin.so I would expect it to crash in other FF versions as well in the same place.

Looking at the pushes to 1.9.2 I see both bug 544158 and bug 551152 came in on 2010-08-03...perhaps one of those is the culprit?
Btw, they all look like crashes on startup...
Blocks: 582130
Ccing Josh and mike, as the fixes for bug 544158 and bug 551152 came in around the time the "spike" happened.
It would help to know what version of IcedTea is involved. We can search their source code for "NPNVprivateModeBool" and if they are not using it we can rule out bug 544158. I doubt bug 544158 is the cause of this anyway.
bug 551152 was backed out on the 4th.
I grepped through their current source and didn't find NPNVprivateModeBool, so that would seem to rule out bug 544158.
It looks like there might have been some kind of icetea source release around July 29 ( http://icedtea.classpath.org/download/source/?C=M;O=D ) ,  and 5 days later we have moved from in consistently seeing 0-30 crashes per day to 30-46 crashes per day in the iceteaplugin.so.   I wonder if that release is a contributing factor.

http://icedtea.classpath.org/download/source/?C=M;O=D

date     crashes at
         IcedTeaplugin.so

20100701 2
20100702 4
20100703 4
20100704 7
20100705 7
20100706 15
20100707 26
20100708 11
20100709 19
20100710 7
20100711 4
20100712 3
20100713 4
20100714 9
20100715 2
20100718 18
20100719 9
20100720 15
20100721 34
20100722 11
20100723 13
20100724 13
20100725 2
20100726 12
20100727 6
20100728 8
20100729 0
20100730 9
20100731 4
20100801 11
20100802 10
20100803 8
20100804 4
20100805 28
20100806 22
20100807 10
20100808 28
20100809 20
20100810 24
20100811 30
20100815 21
20100816 28
20100817 31
20100818 46
20100819 36
20100820 11
20100821 36
20100822 37
FWIW I loaded the latest 3.6.9 nightly on Ubuntu, installed IcedTea and played around with Java applets. A lot of Java errors in the console but no crashes or issues. It would be nice to have specific URLs to try to reproduce though.
most of the higher volume url's appear to be about:blank (new tab?),  start pages, and session restore.   In fact for aug 19 all 36 reports are inside 3 minutes of start up.  30 of 36 are inside 30 seconds.

I think we might looking for a startup/compat crash here, but here are some urls in a larger sample of the data for the whole month.

   2 20100822-crashdata.csv:IcedTeaPlugin.so@0xaa15 http://ziogeek.com/forum/medley-hmr-unofficial-generale/firmware-medley-2-a-vt1318.html 3.6.9pre \N

   3 20100816-crashdata.csv:IcedTeaPlugin.so@0xaa15 http://www.mozilla.org/projects/minefield/ 4.0b4pre \N
   3 20100818-crashdata.csv:IcedTeaPlugin.so@0x873c 
http://guiodic.wordpress.com/2010/05/06/aggiornare-i-driver-nvidia-su-ubuntu-10-04-lucid/ 

3.6.9pre \N
   3 20100818-crashdata.csv:IcedTeaPlugin.so@0x873c 
http://start.ubuntu.com/10.04/Google/ 3.6.9pre \N

   3 20100821-crashdata.csv:IcedTeaPlugin.so@0xaa15 http://www.manoramaonline.com/advt/Lifestyle/Miss-Universe-2010/index.htm 3.6.9pre \N
   3 20100822-crashdata.csv:IcedTeaPlugin.so@0x873c 
http://www.bbc.co.uk/go/rss/int/news/-/news/uk-11050587 3.6.9pre \N

   3 20100822-crashdata.csv:IcedTeaPlugin.so@0xaa15 
http://flash-aid-extension.blogspot.com/ 3.6.9pre \N
   3 20100822-crashdata.csv:IcedTeaPlugin.so@0xaa15 
http://ubuntuforums.org/showthread.php?t=1339259 3.6.9pre \N
Note that we're also seeing this on Thunderbird (see bug 582130), afaik all we do there is load the plugin to check its version info, we actually (by default) block objects being loaded into plugins via the content policy.

Some of the comments on our crashers:

http://crash-stats.mozilla.com/report/list?range_value=2&range_unit=weeks&date=2010-08-25%2012%3A00%3A00&signature=IcedTeaPlugin.so%400x873c&version=Thunderbird%3A3.1.2
(In reply to comment #6)
> It looks like there might have been some kind of icetea source release around
> July 29 ( http://icedtea.classpath.org/download/source/?C=M;O=D ) ,  and 5 days
> later we have moved from in consistently seeing 0-30 crashes per day to 30-46
> crashes per day in the iceteaplugin.so.

But we aren't seeing a big spike in released builds, right? I would expect the spike to be even higher (in #'s, not percentages) for 3.6.8 if the issue was indeed caused by a new IcedTeaPlugin.
Is this bug still of value? We have bug 582130 open on some IcedTeaPlugin.so issue as well and we don't really have a signature here. Also, I have no idea if we can even do anything about it anyhow.
Is this still an issue ?
Not able to reproduce on Linux x86 on FF 19b5 and Latest Nightly (2013-02-10). Should it be Resolved WFM?
(In reply to Paul Silaghi [QA] from comment #12)
> Is this still an issue ?

Marking this as WFM based on Comment 13. If anyone can still reproduce this issue please REOPEN it.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Issue is resolved - clearing old keywords - qa-wanted clean-up
You need to log in before you can comment on or make changes to this bug.