Title bar has wrong height if not maximized with custom window themes (cracked uxtheme.dll)

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
P1
normal
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: WL, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre

In Win32 XP, when the window is not maximized, the title bar is much higher than it should be.

Reproducible: Always

Steps to Reproduce:
Mozilla/5.0 (Windows NT 5.1; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre
Win32 XP
(Reporter)

Updated

8 years ago
Blocks: 513162
Priority: -- → P1
(Reporter)

Comment 1

8 years ago
Created attachment 465097 [details]
maximized window
(Reporter)

Comment 2

8 years ago
Created attachment 465098 [details]
not maximized

Comment 3

8 years ago
(In reply to comment #2)
> Created attachment 465098 [details]
> not maximized

What type of theme / theme software are you using?
(Reporter)

Comment 4

8 years ago
Seems like you guys backed out the changes for XP in following nightly builds.
If you can read some Chinese, here is the website from where I downloaded the theme:
http://www.dzart.net/
But I can't remember exactly the one I'm using, I guess:
http://www.dzart.net/?controller=Front_Default&action=View&Id=1154

Comment 5

8 years ago
(In reply to comment #4)
> Seems like you guys backed out the changes for XP in following nightly builds.
> If you can read some Chinese, here is the website from where I downloaded the
> theme:
> http://www.dzart.net/
> But I can't remember exactly the one I'm using, I guess:
> http://www.dzart.net/?controller=Front_Default&action=View&Id=1154

Those landed last night. Do these need custom theme software to apply, or are they just generic windows xp themes?
(Reporter)

Comment 6

8 years ago
Those themes are packed into win32 executable,but I believe they are generic themes. Thus it may not be true as I installed 2-3 years ago.
I will check it on my XP box tomorrow.

Comment 7

8 years ago
Created attachment 469255 [details]
screenshot (left:maximized)

Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100825 Minefield/4.0b5pre ID:20100825062325

maybe your theme issue.
(Reporter)

Comment 8

8 years ago
Created attachment 469315 [details]
moz vs. opera

It's the screen shots for "Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100825 Minefield/4.0b5pre" and Opera, so I don't think it's a theme issue, right?

Comment 9

8 years ago
@WL

why don't you check with/on XP default OS Theme ?
(Reporter)

Comment 10

8 years ago
Created attachment 469328 [details]
close button only

It works fine with default theme. But current solution can't cooperate with some other custom themes while Opera handle them pretty well.

Comment 11

8 years ago
Created attachment 469332 [details]
screenshot (XP default Theme::Windows XP Style and Windows Classic Style)

(In reply to comment #10)
> Created attachment 469328 [details]
> close button only

it seems to be not default Theme.
it's like Vista/7 Theme.

and nothing to do with Opera or other software.
problem with 3rd party theme/software or something is not a Firefox bug.
(Reporter)

Comment 12

8 years ago
I can't agree.
Firefox are using the native widgets. How can you make a conclusion that it's an issue of 3rd party theme while the other applications work fine using the same theme?

Comment 13

8 years ago
maybe you think "software A (3rd party theme)" is compatible with "software B (Opera)"
so "software A" is always compatible with "software C (Minefield)"

This is not true.

your 3rd party Theme is compatible with Opera, BUT not with Minefield.

that's all.
(Reporter)

Comment 14

8 years ago
Ooooops. Let's stop spamming this bug.

Comment 15

8 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Seems like you guys backed out the changes for XP in following nightly builds.
> > If you can read some Chinese, here is the website from where I downloaded the
> > theme:
> > http://www.dzart.net/
> > But I can't remember exactly the one I'm using, I guess:
> > http://www.dzart.net/?controller=Front_Default&action=View&Id=1154
> 
> Those landed last night. Do these need custom theme software to apply, or are
> they just generic windows xp themes?

I couldn't find the download here for the actual windows theme files. There was a download to some exe but in an image it spammed the system with all sort of junk. If we could track down the actual theme, we could probably diagnose this.
(Reporter)

Comment 16

8 years ago
Created attachment 469746 [details]
theme tiger green

Please extract to %SystemRoot%\resources\themes.
I've scanned for viruses already, but you can also check it yourself.
Thanks.

Comment 17

8 years ago
(In reply to comment #16)
> Created attachment 469746 [details]
> theme tiger green
> 
> Please extract to %SystemRoot%\resources\themes.
> I've scanned for viruses already, but you can also check it yourself.
> Thanks.

Double clicking on the theme file doesn't load the theme. I'm guessing this is similar to bug 577509, which involves 3rd party themeing software. We can try to address this, but odds are it will be up to the vendor that publishes the themeing platform.
(Reporter)

Comment 18

8 years ago
Please extract to directory %SystemRoot%\resources\themes first.
You need a cracked version of uxtheme.dll (%SystemRoot%\system32\) to use 3rd party themes directly.
Shall we mark this bug as duplicated (bug 577509)?
(In reply to comment #18)
> Please extract to directory %SystemRoot%\resources\themes first.
> You need a cracked version of uxtheme.dll (%SystemRoot%\system32\) to use 3rd
> party themes directly.
> Shall we mark this bug as duplicated (bug 577509)?

I don't think that is needed since StarDock is a vendor in and of itself that needs to address their issues with the newest versions of Firefox.

Comment 20

8 years ago
Added 'with custom window themes (cracked uxtheme.dll)' to the subject, as this problem only occurs with custom window themes.
Summary: Title bar has wrong height if not maximized → Title bar has wrong height if not maximized with custom window themes (cracked uxtheme.dll)
(Reporter)

Comment 21

8 years ago
It works for me in latest nightly from nearly one month ago, so I think it's fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.