[API] Put the C in CRUD for the Version model

RESOLVED FIXED in 5.12.1

Status

P1
normal
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: clouserw, Assigned: davedash)

Tracking

unspecified
5.12.1

Details

(Whiteboard: [devtools][Q32010][qa-])

(Reporter)

Description

8 years ago
Weak Spec: https://wiki.mozilla.org/User:Clouserw/AMO/API
Piston Docs: http://bitbucket.org/jespern/django-piston/wiki/Documentation#piston-documentation

This is for the /api/addon/:id/versions/:id fields.  This should use the JSONEmitter and accept at least JSON as input.  This should use our OAUTH setup for authentication.
(Reporter)

Updated

8 years ago
Target Milestone: 5.11.9 → 5.12
(Reporter)

Comment 1

8 years ago
dd is doing the CRUD for add-ons, so this seems like a natural fit.  We'll talk about schedule/priority
Assignee: nobody → dd
(Reporter)

Updated

8 years ago
Target Milestone: 5.12 → 5.12.1
http://github.com/jbalogh/zamboni/commit/50b6d84
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Duplicate of this bug: 689539
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.