Theme should have an uninstaller

VERIFIED DUPLICATE of bug 71194

Status

P1
normal
VERIFIED DUPLICATE of bug 71194
18 years ago
3 years ago

People

(Reporter: markpeak, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Should have Theme Uninstaller in Pref > Theme.
maybe a button like 'Uninstall Thinice'.
Classic and Modern won't be removed anyway.
over to Themes.
Assignee: ben → hangas
Component: XP Apps: GUI Features → Themes
QA Contact: sairuh → pmac

Updated

18 years ago
Assignee: hangas → dveditz
Status: UNCONFIRMED → NEW
Component: Themes → Installer: XPInstall Engine
Ever confirmed: true
QA Contact: pmac → jimmylee

Comment 2

18 years ago
I think this belongs to the installer engine.
Let's leave this with Install for now, but perhaps it really goes in the Themes 
preference panel.

I'll take this bug as covering only uninstalling "profile" skins; globally 
installed skins will get covered by the general XPInstall uninstaller we're 
planning.
Status: NEW → ASSIGNED

Comment 4

18 years ago
*** Bug 59134 has been marked as a duplicate of this bug. ***
Keywords: nsbeta1
Priority: P3 → P1
Summary: Theme should have an uinstaller → Theme should have an uninstaller

Comment 5

18 years ago
This is especially important since the individual themes are not clearly
isolated from each other and the program in the filestructure.

It would be nice to also just be able to delete a theme's subdir (e.g.
\graymodern - although this is the best theme so far ;-) But that is probably
another bug...
Whiteboard: [xpiprd]
Moz 0.9 tasks
Target Milestone: --- → mozilla0.9

Comment 7

18 years ago
I think this depends on bug 59558 (I'm assuming that bug isn't Mac-only).

See also bug 7884, general "uninstall" for xpinstall.
Depends on: 59558

Comment 8

18 years ago
It would be really nice to have this.
(Reporter)

Comment 9

18 years ago
May we call this uninstaller 'Theme Manager'?
like Linux X-Window (KDE, Gnome) Theme Manager.

Comment 10

18 years ago
why not simply put a button in prefs next to "Apply themename" called "Delete
Selected Theme"?
Please see original comments in the bug "...in Pref > Theme maybe a button ..."

Comment 12

18 years ago
this is prolly something that needs to be right smack in the middle of themes
prefs. reassigning benb
Assignee: dveditz → ben
Status: ASSIGNED → NEW

Comment 13

18 years ago
Since this got reassigned from dveditz to ben by syd, marking nsbeta1- and
resetting target milestone since I don't think this will fit on Ben's plate for
beta1
Keywords: nsbeta1 → nsbeta1-
Target Milestone: mozilla0.9 → ---

Comment 14

18 years ago
I notice the [xpiprd] in the status whiteboard from dveditz, which means
that someone is supposed to deliver this. Dan, is this really your bug?
We thought this would be sufficient for now with a button on the Preferences 
dialog which calls hyatt's uninstall stuff, without actually removing the 
chrome .jar (because there might be multiple skins in a .jar), therefore this 
is just a UI thing.

I bet TPringle doesn't know this was cut, and this is just about the top thing 
marketing wants from the release. re-nominating.
Keywords: nsbeta1- → nsbeta1
Whiteboard: [xpiprd]

Comment 16

18 years ago
This is a must have for beta1.  The loudest and most consistent feedback on
themes is that we need an uninstaller.  Paul, is there someone besides Ben that
could implement this in the UI?

Comment 17

18 years ago
Ccing Patty.  She will be involved with testing this implementation.
*** Bug 71177 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
Sure, now I find this.  Check out bug 71194, where I threw together what could
be the start of the front-end work.

Comment 20

18 years ago
OK, the API is now in, is anyone now looking onto this bug, which seems only to
be to put in a UI in prefs?
This is fixed now...

*** This bug has been marked as a duplicate of 71194 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 22

18 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.