Unable to uninstall .xpi packages

VERIFIED DUPLICATE of bug 161508

Status

Core Graveyard
Installer: XPInstall Engine
P3
enhancement
VERIFIED DUPLICATE of bug 161508
18 years ago
2 years ago

People

(Reporter: Jimmy Lee, Assigned: Syd Logan)

Tracking

(Blocks: 1 bug, {helpwanted})

Trunk
mozilla1.1alpha
helpwanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 6/9/99 SeaMonkey build

1. Trigger http://jimbob/jars/a_adduninstall.jar to set up package

      Install.StartInstall("Acceptance: a_adduninstall", "a_uninstall", vi, 0);
      f = Install.GetFolder("Program", "uninstall_dir");
      err = Install.AddSubcomponent(regName, vi, jarSrc, f, jarSrc, true);

2. Trigger http://jimbob/jars/a_uninstall.jar to uninstall package

      err2 = Install.Uninstall("a_uninstall");

RESULT:
a_adduninstall.jar appears to trigger successfully.  The component is installed
as expected.  The Uninstall registry appears correct.

Triggering a_uninstall.jar results in err2 = -213 (no such component).  The
Install.log indicates that the installscript aborts.  The package is not
uninstalled.  The Uninstall registry for the installed component is not removed.

EXPECTED RESULT:
Triggering a_uninstall.jar results in the package being uninstalled.  The
Uninstall registry is updated with this node removed.  The Install.log reflects
a successful uninstall.

Updated

18 years ago
Assignee: dougt → dveditz
Target Milestone: M10

Comment 1

18 years ago
setting target milestone to M10
reassign to dveditz

Comment 2

18 years ago
I have made numberous bug fixes which might cause some of these bugs to go away.
 I am going to mark them as FIXED so that they may be verified.
(Reporter)

Updated

18 years ago
Status: RESOLVED → REOPENED
(Reporter)

Comment 3

18 years ago
Build 7/30/99

No changes seen.  This is still a problem.

Updated

18 years ago
Resolution: FIXED → ---

Comment 4

18 years ago
Clearing Fixed resolution due to reopen.

Updated

18 years ago
Assignee: cathleen → dbragg

Updated

18 years ago
Depends on: 9590
Target Milestone: M10 → M11

Comment 5

18 years ago
depends on bug 9590

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Assignee: dbragg → dveditz
Status: ASSIGNED → NEW
Target Milestone: M11 → M14

Comment 6

18 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine

Updated

18 years ago
Target Milestone: M14 → M17

Comment 7

18 years ago
uninstall is not part of beta 1 requirement.
Status: NEW → ASSIGNED

Comment 8

18 years ago
put on helpwanted 
uninstall in xpinstall/smartupdate is out.
Assignee: dveditz → cathleen
Status: ASSIGNED → NEW
Keywords: helpwanted
Summary: Uninstall: Unable to uninstall successfully → [feature]Uninstall: Unable to uninstall (XPInstall)
Target Milestone: M17 → M30
Parcelling out Cathleen's bugs
Assignee: cathleen → dveditz

Comment 10

17 years ago
Adding [nsbeta2-] since this is an identified feature which was cut.  Per 
today's beta2 XP Install status review.
Whiteboard: [nsbeta2-]
Changing fictional "M30" to reality
Target Milestone: M30 → Future
Adding nsbeta2 keyword to bugs with nsbeta2 triage value in status field so the 
queries don't get screwed up
Keywords: nsbeta2

Comment 13

17 years ago
*** Bug 50948 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
See also bug 58706, which covers uninstalling themes.

Comment 15

17 years ago
*** Bug 71177 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
kerz:  We'd really like this for the media player, especially since installing
the media player increases browser startup time (and new window time) quite a bit.

Comment 17

16 years ago
The OS should be changed from "Windows NT" to "All".  No matter what platform
you are using, if you can install a package you should be able to uninstall it
as well.

I'd make the change myself, but I'm not sexy enough.
Yes, this is a cross-platform bug.

(Why would media player affect new window time?)
Severity: normal → enhancement
Keywords: nsbeta2
OS: Windows NT → All
Summary: [feature]Uninstall: Unable to uninstall (XPInstall) → Unable to uninstall .xpi packages
Whiteboard: [nsbeta2-]
*** Bug 96409 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 97319
Nominating
Keywords: mozilla1.0

Updated

16 years ago
Keywords: oeone
Status: NEW → ASSIGNED

Updated

16 years ago
Keywords: oeone

Comment 21

16 years ago
I'm not sure if there's a method for showing the packages (about:xpi?) but that
should probably be a portion of the uninstaller.
*** Bug 138358 has been marked as a duplicate of this bug. ***
*** Bug 139523 has been marked as a duplicate of this bug. ***

Comment 24

16 years ago
*** Bug 139970 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 25

15 years ago
Currently working on a requirements document for this.
Assignee: dveditz → syd
Status: ASSIGNED → NEW
Target Milestone: Future → mozilla1.1alpha
Blocks: 112869

Comment 26

15 years ago
is this dupe of bug 161508 ?
whats the difference?

Updated

15 years ago
Blocks: 197133
marking as dup of bug 161508  because that bug actually has a patch

*** This bug has been marked as a duplicate of 161508 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Depends on: 161508

Comment 28

14 years ago
A bug can't be both a duplicate of and blocked by the same bug.
No longer depends on: 161508

Updated

14 years ago
No longer depends on: 9590

Updated

14 years ago
No longer blocks: 112869
verified duplicate

Updated

14 years ago
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.