Closed Bug 58707 Opened 24 years ago Closed 24 years ago

Middle-click pastes at end-of-line in TEXTAREA pastes text in wrong place

Categories

(Core :: Layout: Form Controls, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 48786

People

(Reporter: sgifford+mozilla-old, Assigned: rods)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; m18) Gecko/20001014
BuildID:    0000000000 (CVS 10/31/2000)

If I am in a TEXTAREA and have text selected elsewhere, when I
middle-click past the end of line to paste it, it pastes incorrectly, sometimes
going down to the next line, sometimes jumping up and pasting there (!)


Reproducible: Always
Steps to Reproduce:
1. Type a few lines of text in a TEXTAREA

2. Select text from the same or another window

3. Middle-click past the end of a line

4. If text pastes correctly, repeat a few times

Actual Results:  Text is pasted on next line, or on previous line.

Expected Results:  Text being pasted at cursor.

This may be related to bug #53610.  It was originally reported as bug #56325;
other issues in the bug have been fixed or marked duplicate, but this portion of
the bug is still broken.
This looks like a dupe of bug 48786
Yup, sure is a dup.  Sorry, I must have done my query wrong before opening.


*** This bug has been marked as a duplicate of 48786 ***
Status: UNCONFIRMED → RESOLVED
Closed: 24 years ago
Resolution: --- → DUPLICATE
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.