Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Expose whether direct2d is enabled to about:support

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Tracking

(Blocks: 1 bug)

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

7 years ago
Created attachment 465757 [details] [diff] [review]
Add a graphics section to about:support that included whether d2d is enabled
(Assignee)

Updated

7 years ago
Attachment #465757 - Flags: review?(johnath)
(Assignee)

Updated

7 years ago
OS: Mac OS X → All
I assume we can't just get this from looking at modified prefs (already included in about:support)?
(Assignee)

Comment 2

7 years ago
(In reply to comment #1)
> I assume we can't just get this from looking at modified prefs (already
> included in about:support)?

Correct. The prefs say whether direct2d is explicitly desired. This says whether it's actually being used.
Comment on attachment 465757 [details] [diff] [review]
Add a graphics section to about:support that included whether d2d is enabled

CC/CI -> Cc/Ci, and don't double declare var d2d. If you fix those, run it, and it actually works, r=me on the obvious, fixed version.

Direct2D is not a string that needs to be localized, so I'm okay for it to be in there bare, but I wonder if it might be helpful to turn it into an actual sentence, given the distinction between "direct2d prefs are on, aspirationally" and "direct2d is actually functioning"? E.g.

"Direct2D Enabled" or "Direct2D Active"

Your call, really.
Attachment #465757 - Flags: review?(johnath) → review-
(Assignee)

Comment 4

7 years ago
Created attachment 465830 [details] [diff] [review]
v2
Attachment #465757 - Attachment is obsolete: true
Attachment #465830 - Flags: review?(johnath)
(Assignee)

Comment 5

7 years ago
Wrong patch
(Assignee)

Comment 6

7 years ago
Created attachment 465832 [details] [diff] [review]
v3
Attachment #465830 - Attachment is obsolete: true
Attachment #465830 - Flags: review?(johnath)
(Assignee)

Updated

7 years ago
Attachment #465832 - Flags: review?(johnath)
(Assignee)

Comment 7

7 years ago
http://hg.mozilla.org/mozilla-central/rev/032abd339649
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 584179
(Assignee)

Updated

7 years ago
Attachment #465832 - Flags: review?(johnath)

Updated

7 years ago
Depends on: 592406

Updated

7 years ago
No longer depends on: 592406

Updated

7 years ago
Blocks: 594464

Updated

6 years ago
Assignee: nobody → jmuizelaar
You need to log in before you can comment on or make changes to this bug.