configure on linux requires YASM with --disable-compile-environment

RESOLVED FIXED in mozilla2.0b4

Status

defect
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: unghost, Assigned: khuey)

Tracking

unspecified
mozilla2.0b4

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

--disable-compile-environment fails with a following error when trying to build
a langpack for Firefox 4.0 on Ubuntu 10.04:

checking for YASM assembler... checking for yasm... no
configure: error: yasm is a required build tool for this architecture when webm is enabled. You may either install yasm or --disable-webm (which disables the WebM video format). See https://developer.mozilla.org/en/YASM for more details.
*** Fix above errors and then restart with               "make -f client.mk build"
make: *** [configure] Error 1
make: *** browser/locales: No such file or directory.  Stop.

Perhaps this is caused by Bug 582955
Yes, it is.
Assignee: nobody → me
Status: NEW → ASSIGNED
blocking2.0: --- → ?
Target Milestone: --- → mozilla2.0b4
Posted patch PatchSplinter Review
Only error when there is a compile environment.
Attachment #466036 - Flags: review?(ted.mielczarek)
Comment on attachment 466036 [details] [diff] [review]
Patch

I'm not technically a m-c build reviewer but I am a c-c one, so take my review at your own discretion.
Attachment #466036 - Flags: review+
Attachment #466036 - Flags: approval2.0+
(In reply to comment #3)
> Comment on attachment 466036 [details] [diff] [review]
> Patch
> 
> I'm not technically a m-c build reviewer but I am a c-c one, so take my review
> at your own discretion.

Good enough for this I think.

http://hg.mozilla.org/mozilla-central/rev/07822d2a6758
Status: ASSIGNED → RESOLVED
blocking2.0: ? → ---
Closed: 9 years ago
Resolution: --- → FIXED
Comment on attachment 466036 [details] [diff] [review]
Patch

>-      if test -n "$VPX_X86_ASM" -a -z "$VPX_AS"; then
>+      if test "$COMPILE_ENVIROMENT" -a -n "$VPX_X86_ASM" -a -z "$VPX_AS"; then
Doesn't that need an extra -n ?

What about localisers running on Windows, if we have any?
(In reply to comment #5)
> Comment on attachment 466036 [details] [diff] [review]
> Patch
> 
> >-      if test -n "$VPX_X86_ASM" -a -z "$VPX_AS"; then
> >+      if test "$COMPILE_ENVIROMENT" -a -n "$VPX_X86_ASM" -a -z "$VPX_AS"; then
> Doesn't that need an extra -n ?

No, we do it this way all over the place http://mxr.mozilla.org/mozilla-central/search?string=COMPILE_ENVIRONMENT

> 
> What about localisers running on Windows, if we have any?

That's been fatal since the initial landing at http://hg.mozilla.org/mozilla-central/rev/1a95c30ec47b.  That said, it should be fixed too.
Attachment #466036 - Flags: review?(ted.mielczarek) → review+
I don't have a windows setup these days, can you file a bug with a constructive summary?
You might want to correct the variable name (missing N before M)...
(In reply to comment #8)
> You might want to correct the variable name (missing N before M)...

Nice.  http://hg.mozilla.org/mozilla-central/rev/7ad51f9290e8
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.