Closed Bug 587576 Opened 11 years ago Closed 11 years ago

App tabs are too small / narrow and hard to target / click

Categories

(Firefox :: Theme, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 4.0b5

People

(Reporter: naylor83, Assigned: dao)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100815 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100815 Minefield/4.0b4pre

App tabs are currently just 27 pixels wide (on Windows 7 with default font size).

It would help targeting if they were made ~4 pixels wider. (They would also look better! See screenshot & mockup.)

Reproducible: Always

Steps to Reproduce:
1. Open a few tabs.
2. Make one or two into app tabs.
3. Look at the width of the app tabs.
Actual Results:  
App tabs are 27 px wide.

Expected Results:  
App tabs should be 31 px wide.
Blocks: pinnedtabs
Component: Tabbed Browser → Theme
QA Contact: tabbed.browser → theme
Oops. This is a dupe of 577039.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577039
(In reply to comment #3)
> Oops. This is a dupe of 577039.

Nope. This might block bug 577039 or bug 577039 might be a duplicate of this one, since this bug's summary is more specific...
Ok. Well feel free to reopen if it should be reopened.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
AppTabs will have size of New tab tab.
First and foremost, they'll have a size that satisfies a compromise between usability and compactness. This isn't necessarily the size of the new tab button, which varies depending on where the button is placed.
Every single mockup I saw had the same size for New Tab tab, Home Tab and AppTabs. Having different sizes of each tab will look hilarious at best.
I like hilarious.
Me too.
Assignee: nobody → dao
OS: Windows 7 → All
Hardware: x86_64 → All
Attached patch patchSplinter Review
Attachment #469006 - Flags: review?(dolske)
Blocks: 579373
Attachment #469006 - Flags: review?(dolske) → review?(gavin.sharp)
Attachment #469006 - Flags: review?(gavin.sharp) → review+
Attachment #469006 - Flags: approval2.0?
Attachment #469006 - Flags: approval2.0?
http://hg.mozilla.org/mozilla-central/rev/4496d883d113
Status: NEW → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b5
Version: unspecified → Trunk
Verified fixed
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100827 Firefox/4.0b5pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.