Status

defect
--
blocker
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: ahoza, Assigned: mwu)

Tracking

Firefox Tracking Flags

(fennec2.0a1+)

Details

Attachments

(1 attachment)

Reporter

Description

9 years ago
BuildId: 20100816005603
Build FTP location: http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-maemo5-gtk/
Device: Nokia N900

bug 587509, bug 587516, bug 587521, bug 587522 are still reproducible on 8/16 nightly build

and there are other problems:

- System pages, excluding about:config, are not working on my device.
- "X" button not working when more than one tab is opened. When minimizing window and tapping "X", Fennec is closed with no warning dialog.
- history is not saved
- about:config is empty
- Settings-Add-ons - searching for an add-on does not return a result (it looks as if it enters in an infinite loop)
- cannot open more than one link in visited pages (e.g: enter in the URL bar: yahoo.com; after page loads open a link from the page; if it works try "Back" and open another link; most of the times first accessed linked is not opened either)
- context menu not opened when long tapping on links/images
- cannot edit bookmarks through  See all bookmarks -> long tap on a bookmark
Reporter

Updated

9 years ago
tracking-fennec: --- → ?
Reporter

Comment 1

9 years ago
Changing platform as there are same problems on latest nightly Android build as well - device HTC Desire A8181.
OS: Maemo → All
Hardware: x86 → All
I'm not seeing any of these issues in a desktop (Linux i686, GTK) trunk build. 
Maybe they are related to bug 587236 and bug 587183.
Hardware: All → ARM
about:config is empty on my desktop build, and we're hitting an assertion:

###!!! ASSERTION: Content should not be calling this: 'Not Reached', file ../../../chrome/src/nsChromeRegistryContent.cpp, line 262
------------------------------------------------------------------------
Hit JavaScript "debugger" keyword. JS call stack...
0 anonymous() ["chrome://browser/content/bindings/browser.xml":464]
    this = [object Object]
1 get_contentDocument() ["chrome://global/content/bindings/browser.xml":0]
    this = [object XULElement @ 0x7fffd7b80240 (native @ 0x7fffd7a48480)]
2 updateViewportSize() ["chrome://browser/content/browser.js":2523]
    contentDocument = undefined
    metaData = [object Object]
    browser = [object XULElement @ 0x7fffd7b80240 (native @ 0x7fffd7a48480)]
    this = [Tab about:config]
3 updateViewportMetadata(metaData = [object Object]) ["chrome://browser/content/browser.js":2485]
    browser = [object XULElement @ 0x7fffd7b80240 (native @ 0x7fffd7a48480)]
    this = [Tab about:config]
4 receiveMessage(aMessage = [object Object]) ["chrome://browser/content/browser.js":1279]
    json = [object Object]
    this = [object Object]

so it looks like we're trying to update the window's meta data from the content process.
tracking-fennec: ? → 2.0a1+
Assignee

Comment 4

9 years ago
Posted patch FixSplinter Review
Adds Jacob Bramley's "Fix ARM's load8 implementation and enable YARR for ARM." fix and adjusts stuff accordingly to actually build yarr.
Assignee: nobody → mwu
Attachment #466433 - Flags: review?
Assignee

Updated

9 years ago
Attachment #466433 - Flags: review? → review?(sayrer)

Comment 5

9 years ago
Does this fix the bugs?
Assignee

Comment 6

9 years ago
(In reply to comment #5)
> Does this fix the bugs?
According to mfinkle, yes. I didn't see any regressions on a build with this patch.

Updated

9 years ago
Attachment #466433 - Flags: review?(sayrer) → review+
Assignee

Comment 7

9 years ago
http://hg.mozilla.org/mozilla-central/rev/dbc17795f035
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 587509
Thanks! Everything seems to be working again with the 20100817 build of Fennec2.0a1pre on the n900.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.