Closed Bug 587608 Opened 12 years ago Closed 12 years ago

Feed reader broken by regexp failure

Categories

(MailNews Core :: Feed Reader, defect)

defect
Not set
normal

Tracking

(blocking-seamonkey2.1 a3+)

RESOLVED FIXED
Tracking Status
blocking-seamonkey2.1 --- a3+

People

(Reporter: neil, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Bug 587366 means that encoded = encoded.replace("?", "%3f", "g"); doesn't work.
Attached patch Workaround (obsolete) — Splinter Review
Attachment #466278 - Flags: feedback?(misak.bugzilla)
blocking-seamonkey2.1: --- → ?
Duplicate of this bug: 587609
Comment on attachment 466278 [details] [diff] [review]
Workaround

This patch fixes my feeds.
Attachment #466278 - Flags: feedback?(misak.bugzilla) → feedback+
Attachment #466278 - Flags: superreview?(bugzilla)
Attachment #466278 - Flags: review?(iann_bugzilla)
blocking-seamonkey2.1: ? → a3+
Actually, to me, the code in this "workaround" patch looks better to me than the original code. I wonder if there's a significant speed difference in today's JS at all, i.e. if it wouldn't be better to just stick to that workaround "forever".
Duplicate of this bug: 587737
There were two problems with the previous workaround:
1. encodeURIComponent uses upper case.
2. encodeURIComponent doesn't actually encode ~s
   (The similar escape method encodes ~s but not /s ...)
This causes previously read messages to be redetected.
I don't know which of these need \s but I thought better safe than sorry.
Attachment #466278 - Attachment is obsolete: true
Attachment #466610 - Flags: review?(iann_bugzilla)
Attachment #466278 - Flags: superreview?(bugzilla)
Attachment #466278 - Flags: review?(iann_bugzilla)
I pushed attachment 466610 [details] [diff] [review] as http://hg.mozilla.org/comm-central/rev/d24027998497 on the SeaMonkey 2.1a3 relbranch so that we can get a working build2 done today.
Attachment #466610 - Flags: review?(iann_bugzilla) → review+
Attachment #466610 - Flags: superreview?(bienvenu)
Attachment #466610 - Flags: superreview?(bienvenu) → superreview+
Pushed changeset 4a250eaee18f to comm-central.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
I'm getting :
Error: invalid quantifier
Source File: chrome://messenger-newsblog/content/utils.js
Line: 420 whic correspond to  encoded = encoded.replace("?", "%3f", "g");


On TB today's nightly and I still don't get feed updates. Shall I file a new bug for this ?
(In reply to comment #9)
> On TB today's nightly and I still don't get feed updates. Shall I file a new
> bug for this ?

Today's nightlies aren't out yet - you've got yesterdays ;-)
You need to log in before you can comment on or make changes to this bug.