Closed Bug 587667 Opened 10 years ago Closed 9 years ago

IME doesn't work with Flash 10.1/10.2 on OS X on trunk (using Cocoa event model)

Categories

(External Software Affecting Firefox :: Flash (Adobe), defect)

All
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: smichaud, Unassigned)

References

Details

(Keywords: flashplayer, jp-critical)

The most recent version of the Flash plugin for OS X (10.1r82) now
supports text input on the trunk (which uses the Cocoa event model).
(See bug 571537.)

But it still doesn't support IME:

1) Start a recent Minefield nightly -- one created after the patch for
   bug 512886 landed on 2010-06-09 (which added browser-side support
   for non-inline IME in Cocoa event mode).

2) Open a Flash "movie" that allows text input (for example
   http://www.playercore.com/bugFiles/ime/imekrjp.swf or
   http://www.playercore.com/bugfiles/146162/AddReturnHTML.html)

3) Choose a keyboard from the "flags" menu that (like "U.S." or
   "U.S. Extended") doesn't support IME.

4) Type some text -- it should appear as expected.

5) Choose a keyboard that supports IME (like Kotoeri "Hiragana").

6) Type some text -- it will appear as Roman letters, which is
   incorrect.

   What should happen is that an input window opens near the bottom of
   the browser window, in which non-Roman text appears as you type.

The most likely cause is that the Flash plugin doesn't yet support the
protocol implemented by the patch for bug 512886
(https://wiki.mozilla.org/NPAPI:CocoaEventModel#Text_Input).
Summary: IME doesn't work with Flash 10.1 on trunk (using Cocoa event model) → IME doesn't work with Flash 10.1 on OS X on trunk (using Cocoa event model)
Version: unspecified → 10.x
Steven: Is bug 599323 and instance of this?
> Steven: Is bug 599323 an instance of this?

It's possible.

Check to see if bug 599323 has the same regression range as this bug -- check to see if bug 599323 starts (on the trunk) with the 2010-06-10 Minefield nightly.

Also make sure the reporter of bug 599323 is testing with the latest version of the Flash plugin from Adobe -- 10.1r85 (as far as I know).
Bug 604739 may be a dup of this bug.

If so, this bug hasn't yet been fixed in Flash 10.1r85.
Duplicate of this bug: 604739
The following quote from bug 604739 comment #3 seems to show that
Adobe is aware of this bug and will fix it in a future release.  Can
any of the Adobe folks on this bug comment on this?

> I also tried a beta of the 10.2 flash plugin (10.2.161.23) on OSX
> 10.6 under Firefox 4b8 and it appears to work.
I can confirm that the Flash Player team is working on this bug and has an internal fix. It has not yet been released.
This needs a Core::Plugins bug to track against it and be marked as blocking, or we need to add blocking flags to this component.
Depends on: 607052
I've opened bug 607052.
Contrary to expectations, this bug *hasn't* been fixed in Flash 10.2.
I tested on OS X 10.5.8 with FF 4.0 and Flash 10.2.153.1 (which is the
current version).

Anyone from Adobe care to estimate when this will be fixed in a
release version of the Flash plugin?
Summary: IME doesn't work with Flash 10.1 on OS X on trunk (using Cocoa event model) → IME doesn't work with Flash 10.1/10.2 on OS X on trunk (using Cocoa event model)
This bug has been fixed in Flash Player internal builds and will be in the next release. Thanks for your patience!
I can confirm the issue has fixed with Flash Player 10.3 RC 1.
http://labs.adobe.com/downloads/flashplayer10-3.html
It seems to be resolved by upgrading Flash Player to 10.3 RC 1. :-)

Environment
Mozilla: Firefox 4.0.1
OS: Mac OS X 10.6.5 (10H574) 32bit
IME: AquaSKK 4.1 (2009-12-12)
Flash Player 10.3 is out. We just blogged about that.
http://mozilla.jp/blog/entry/6761/
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I've found that Flash Player 10.1.53.64 when used with Firefox versions 5.x and newer on the Mac (I haven't tested on Windows yet) I can confirm this bug. I tested with the following versions of Firefox for Mac with the results below:

v3.6.13 = GOOD
v5.0.1 = BAD
v7.0.1 = BAD
v8.0 = BAD

Again, this seems to be the case with only Flash Player version 10.1.53.64.  For those of us who have to support older versions of software this is a bit concerning.
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.x → unspecified
You need to log in before you can comment on or make changes to this bug.