Save Link to Disk Dialog Allows multiple 'File Save AS' dialogs to be opened

Status

()

Firefox
File Handling
ASSIGNED
18 years ago
2 years ago

People

(Reporter: Sean Chitwood, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20001023
BuildID:    20001023

After choosing a link that cannot be displayed in mozilla, you are prompted to
open with a Helper App or save to disk. If you select save to disk you can open
as many Windows 'Save As...' dialog as you want if you follow this procedure

Reproducible: Always
Steps to Reproduce:
1) Find a link to MP3 or QuickTime File on the web
2) CLick on the link, when prompted to download or open choose download.
3) With the WIndows 'Save As' Dialog still up, go back to the Mozilla dialog and
Click Ok again and again and again...

Actual Results:  Multiple WIndows File Save as Dialog boxes....

Expected Results:  No additional File Save as Dialog Boxes

Comment 1

18 years ago
Confirmed using:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001031 (trunk 
build) On Win2k

Probably belongs under "XP Apps: GUI Features" component.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

18 years ago
There was some discussion in IRC about whether this was a bug. The opinions were:

1) This maximises user choice so shouldn't be fixed (But another bug about the
crash actually using those Save As Dialogs causes should be filed.)

2) (My opinion) That saving the file to disk like the second stage of a wizard
[Sorry for the MSism] and there should be only 1 second screen, not unlimited.

Comment 3

18 years ago
over to XPApps
Assignee: asa → ben
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh
Unless we see a spec saying this shd be the desired behaviour, we should not fix
this bug. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 5

17 years ago
Reopening, we need to fix this.  This dialog should be modal, no?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 6

17 years ago
Yes, the Save filepicker should be modal to that particular browser window. (It 
should not be modal to the what-shall-I-do dialog, as that dialog should have 
gone away before the filepicker opens.)
spam: over to File Handling. i have not changed the assigned developer [or the
other fields for that matter], so if anyone realizes that a bug should have a
more appropriate owner, go ahead and change it. :)
Component: XP Apps: GUI Features → File Handling
Status: REOPENED → ASSIGNED
Target Milestone: --- → Future

Comment 8

17 years ago
"It should not be modal to the what-shall-I-do dialog, as that dialog should have 
gone away before the filepicker opens."

Ideally that's one option, but that probably would require a large rewrite to fix.

Another fix that's probably much quicker is to make the filepicker modal to the
Open/Save dialog.  There should be nothing stopping me from going back to the
original browser window, as by this point it's not concerned with the download
anymore.
*** Bug 148139 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
Possibly related to this bug (should I report a new one?) :

url is an image only (not html with embedded images)
saveing won't popup the save as dialog until the image has finished loading.
(ctrl-S, file->save as, right click Save Image as)

Behaviour possibly related to #84123 (image information is shown in titlebar
only after image finishes loading).

And also, if there are multiple save requests while image is loading, when load
finishes, multiple save as dialogs will appear.
QA Contact: sairuh → petersen
happens on linux too
OS: Windows NT → All
QA Contact: chrispetersen → file-handling

Updated

2 years ago
Component: File Handling → File Handling
Priority: P3 → --
Product: Core → Firefox
Target Milestone: Future → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.