All users were logged out of Bugzilla on October 13th, 2018

In collections/add, add-ons aren't relisted properly in invalid submission.

VERIFIED FIXED in 5.11.9

Status

P2
normal
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: davedash)

Tracking

Details

(Whiteboard: [z], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 466498 [details]
partially saved add-ons

steps to reproduce:
1.Load https://preview.addons.mozilla.org/en-US/firefox/collections/add
2.Add two personas without filling any other details
3.Click "Create collection"

observed behavior:
Submission fails and page loads with error messages. Notice that add-ons added are still listed without any info.(see screenshot)

Submitting with these partial add-ons causes a traceback.
I think this is potch, but if it's backend, let davedash know.
Assignee: nobody → thepotch
Priority: -- → P2
Target Milestone: 5.11.8 → 5.11.9

Comment 2

8 years ago
It looks like when the error messages, the values for the addon fields aren't being returned. Dave, is this something you could help with? I think it's view-level python, but I can't seem to figure it out.
Assignee: thepotch → dd
http://github.com/jbalogh/zamboni/commits/dc4a370
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Summary: If collection creation fails,add-ons listed are partially saved → In collections/add, add-ons aren't relisted properly in invalid submission.
(Reporter)

Comment 4

8 years ago
verified
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.