Implement Tab Group Specific and Window Specific App Tabs and its preferences UI

RESOLVED WONTFIX

Status

P3
enhancement
RESOLVED WONTFIX
9 years ago
3 years ago

People

(Reporter: Ryuji, Unassigned)

Tracking

unspecified
Future
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Future Firefox 5?)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100817 Minefield/4.0b4pre

App Tabs should be allowed to be tab group specific. 
This is useful for organising work and leisure or other random activities as
this option will allow users to be able to set different App Tabs for different Tab groups, making organising tabs easier. 



Reproducible: Always
(Reporter)

Updated

9 years ago
Blocks: 585689
(Reporter)

Updated

9 years ago
Severity: normal → enhancement
Component: General → TabCandy
Depends on: 578553

Comment 1

9 years ago
discussion in bug 578553
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578553
(Reporter)

Updated

8 years ago
Status: RESOLVED → UNCONFIRMED
Priority: -- → P3
Resolution: DUPLICATE → ---
Summary: Add option to allow App Tabs to be Tab Group Specific → Add option to allow App Tabs in Panorama to be global across Panorama
Whiteboard: Future Firefox 4.Next?
(Reporter)

Comment 2

8 years ago
App Tabs are now Tab Group Specific. 
This is useful for organising work and leisure or other random activities as this option will allow users to be able to set different App Tabs for different Tab groups, making organising tabs easier. 

There are users out there who believe that App Tabs should be global across Panorama and Windows. I believe that this should be an option instead of implementing behaviour that replaces Tab Group specific App Tabs.
QA Contact: general → tabcandy
(Reporter)

Comment 3

8 years ago
According to bug 578553, App Tab will be Global across Panorama in Firefox 4. Tab Group specific App tab will not be implemented hence, I propose that we have it in Firefox 4.next. 

One of the benefit of App Tab being Tab Group specific is that this allow user to organize App Tabs easier and getting less distracted with Facebook or Tweeter App Tabs.(Don't be surprised there are people who make those social services as App Tabs)
Summary: Add option to allow App Tabs in Panorama to be global across Panorama → Add option to allow App Tabs in Panorama to be Group Specific

Comment 4

8 years ago
Any reason that you couldn't use windows to have different app tabs in each of those windows with a number of different groups in those windows?
(Reporter)

Comment 5

8 years ago
Currently Panorama do not show every Tab in every window, it only show all tabs per window. Using different window to have different app tabs, it is easy to organize Tabs by different window when users can Muti-select Tabs. But without Panorama for organizing tabs from one window to another, that makes organizing tabs or app tabs a little more difficult.

Comment 6

8 years ago
(In reply to comment #4)
> Any reason that you couldn't use windows to have different app tabs in each of
> those windows with a number of different groups in those windows?

That proposition totally negates any reason to have panorama in the first place. Why not simply have different windows for different groups altogether then?

Following that thought, would it be a good execution to allow separate groups to optionally be listed as separate windows and simply use Panorama as a way to move tabs around from one window to another. 

I agree that app tabs should be allowed to be group specific and also need to be better indicated as globally when they are, e.g. global page header group.
App tabs will be global across all groups in a window for Firefox4. Punting this bug to post ff4; we may revisit when we do "all windows" (bug 578512).
Target Milestone: --- → Future

Comment 8

8 years ago
This was the best feature of App Tabs, to allow fast switching between groups. I've been drinking green tea all morning and now want to burn something down.

Comment 9

8 years ago
Do you know about Command-` to switch groups?
confirming for discussion post Fx4.0 all-windows work.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug has been marked as "future" (post-ff4.0) but it still blocked our ff4.0 milestone bug; removing blocking.
No longer blocks: 585689

Updated

8 years ago
Duplicate of this bug: 637102

Updated

8 years ago
OS: Windows 7 → All
Hardware: x86 → All
(Reporter)

Updated

8 years ago
Summary: Add option to allow App Tabs in Panorama to be Group Specific → Implement Group Specific and Window Specific App Tabs in Panorama and its preferences UI
Whiteboard: Future Firefox 4.Next? → Future Firefox 5?
(Reporter)

Updated

8 years ago
Depends on: 587873
Summary: Implement Group Specific and Window Specific App Tabs in Panorama and its preferences UI → Implement Tab Group Specific and Window Specific App Tabs and its preferences UI
(Reporter)

Updated

8 years ago
Depends on: 578512, 590488

Updated

8 years ago
No longer depends on: 590488
Panorama itself is already too complex. We should not create another layer of complexity by introducing a niche feature like this. I don't think we want this.
Status: NEW → RESOLVED
Last Resolved: 9 years ago6 years ago
Resolution: --- → WONTFIX

Comment 14

5 years ago
(In reply to Tim Taubert [:ttaubert] from comment #13)
> Panorama itself is already too complex. We should not create another layer
> of complexity by introducing a niche feature like this. I don't think we
> want this.

I think it would be ok to add this feature as an advanced option or can be toggled from about:config.So it wouldn't make tab groups any more complex for the regular users while the expert users can change it as required.Personally that's the only reason im not using tab groups efficiently.
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.