Closed Bug 588355 Opened 9 years ago Closed 9 years ago

group your tabs (tabcandy) view - exits / closes without warning for example via X of window or X in tabcandy area - contrast to normal windows with multiple tabs open where X gives warning

Categories

(Firefox Graveyard :: Panorama, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 588526

People

(Reporter: abittner, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b4) Gecko/20100817 Firefox/4.0b4 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b4) Gecko/20100817 Firefox/4.0b4 ( .NET CLR 3.5.30729; .NET4.0E)

tabcandy group your tabs view shows no warnings at all when simply wanting to exit this view again, or lacks selfexplaining way and functionality to exit such a tabcandy view again. user feels tempted to at least press X on outer window of tabcandy, thus resulting in a complete loss of these tabs. maybe this outer window (operating system X on window border) should actually trigger different behaviour than the X inside the tabcandy area where its on the area around the grouped tabs. :(

Reproducible: Always

Steps to Reproduce:
1. just upgraded ffx4b3 to ffx4b4 candidate build2
2. discovered tabcandy/groupyourtabs
3. used tabcandy/groupyourtabs on existing firefox window with countless tabs
4. wanted to simply go back into the normal window view with ffx main window showing all tabs, but used the X (microsoft windows X control on uppler right corner of the ffx window, and also tried the X inside the tabcandy/groupyourtabs area), and both functions simply close this whole firefox window alltogether without any warning whatsoever - basically lost all my immense number of opened tabs this way :((((( argh!


Expected Results:  
tabcandy/groupyourtabs should also warn the same way when closing this view, or actually simply revert to the normal tabcandy-less/groupyourtabs-less via the X-es function, or present an additional symbol to revert back or at least warn, or display alternate function/button in this warning window like: "do you want to exit tabcandy/groupyourtabs view instead?"



sigh :(
thanks.
Summary: group your tabs (tabcandy) view - exits / closes without warning for example via X of window or X in tabcandy area - contrast to normal windows with multiple tabs oben X gives warning → group your tabs (tabcandy) view - exits / closes without warning for example via X of window or X in tabcandy area - contrast to normal windows with multiple tabs open where X gives warning
So first, just wanted to apologize for having had Tab Candy lose all of your state. It is never acceptable for a computer to waste your time. Luckily, we are working on a better undo mechanism.

https://bugzilla.mozilla.org/show_bug.cgi?id=588526
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 588526
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.