do not offer Firefox 4 Beta 4 updates to PPC users

RESOLVED FIXED

Status

AUS Graveyard
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: beltzner, Assigned: morgamic)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta4+)

Details

Attachments

(1 attachment, 3 obsolete attachments)

In bug 587799 we broke PPC builds for beta 4. No biggie, I don't think we have a lot of beta testers there, but we shouldn't offer updates to Firefox 4 Beta channel users as it will break their face.
Does the update query differentiate between Intel and PPC builds ? 
https://aus2.mozilla.org/update/3/%PRODUCT%/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml

The %BUILD_TARGET% is Darwin_Universal-gcc3 in both cases. So it's OS_VERSION or bust ? Bug 552924 addresses this, but not for builds that are already in the wild.

Failing that, perhaps we can redirect based on the UA ? I have 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3) Gecko/20100805 Firefox/4.0b3
(In reply to comment #1)
> Does the update query differentiate between Intel and PPC builds ? 
> https://aus2.mozilla.org/update/3/%PRODUCT%/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml
> 
> The %BUILD_TARGET% is Darwin_Universal-gcc3 in both cases. So it's OS_VERSION
> or bust ? Bug 552924 addresses this, but not for builds that are already in the
> wild.

I was under the impression the query differentiated, but as you say, we may need to go off of UA string.

How does metrics get the info? UA?
CC'ing Metrics people.

Comment 4

7 years ago
What about those of us who use the PPC build?  A lot of institutions will continue to use PPC machines for a long time.  Users tend to use a machine until it breaks, developers tend to use cutting edge machines.  Yes, not many Beta testers use PPC machines, but most Beta testers are developers, most PPC users will only use production releases.  There is a population of users who would like FF 4 to continue working on PPC machines.

Comment 5

7 years ago
We (metrics) don't know how to differentiate a Intel from a PPC machine - unfortunately
Blocks: 588045
(In reply to comment #4)
> What about those of us who use the PPC build?  A lot of institutions will

This really isn't on-topic for this bug. Right now Beta 4 is broken for PPC, period. We shouldn't offer updates to it. That's all we're talking about.
(In reply to comment #5)
> We (metrics) don't know how to differentiate a Intel from a PPC machine -
> unfortunately

Well, we presently put it in the UA string:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

The bit there that says "Intel Mac OS X 10.6" would say "PPC Mac OS ..."

Updated

7 years ago
blocking2.0: --- → ?
Pretty big priority; any ideas, morgamic?
blocking2.0: ? → beta4+
(Assignee)

Updated

7 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

7 years ago
We'll have to make it dirty, but it's possible.  Something along the lines of:
if (UA has 'PPC' && appVersion=? && channel=?) { don't do updates }

What version and channel are we looking for?  v=4.0b3, channel=betatest?
(Assignee)

Comment 10

7 years ago
Created attachment 468495 [details] [diff] [review]
v1, adds workaround, but not pretty

This will offer no updates for any 4.0b3 clients with PPC in the UA string.  Needs testing.
Attachment #468495 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #468495 - Flags: review? → review?(nrthomas)
beltzner, which of these do you want ?

a)   Intel:    all versions --> 4.0b4
     PPC:      no update, stick with whatever you have

b)   Intel:    old version  --> 4.0b3 --> 4.0b4
     PPC:      old version  --> 4.0b3

a) can be done by blocking PPC in the UA for incoming version 3.7* or 4.0b*, and use the snippets we already have. Channels in use are betatest & releasetest (QA), and beta (end users) - we don't need different behaviour per channel

b) can be done by blocking PPC in the UA for incoming version 4.0b3, and doing the snippets differently (only pushing b3->b4 updates).

If PPC is getting dropped anyway then I'd advocate a) as simpler for RelEng and no-retesting for QA.
I want (a) - simplest and easiest. We haven't made the final call on PPC, but it is not likely long for this world.
Comment on attachment 468495 [details] [diff] [review]
v1, adds workaround, but not pretty

Guess we need wildcard matching on 3.7a* and 4.0b* then. Otherwise looks good.
Attachment #468495 - Flags: review?(nrthomas) → review-
(Assignee)

Comment 14

7 years ago
Created attachment 468530 [details] [diff] [review]
v2, adds expressions, thus creating mo' problems

Ewww.  Just what I wanted - regexes.  :\
Attachment #468495 - Attachment is obsolete: true
Attachment #468530 - Flags: review?(nrthomas)
Comment on attachment 468530 [details] [diff] [review]
v2, adds expressions, thus creating mo' problems

>Index: index.php
>+if ( $clean['product'] == 'Firefox'
>+     && preg_match($clean['version'], '/^4\.0.+/')
>+     && preg_match($clean['version'], '/^3\.7.+/')

r+ if we match on 3.7 OR 4.0, and /^4\.0.*/ so that we block PPC updates when '4.0' comes along (with PPC support likely dropped).
Attachment #468530 - Flags: review?(nrthomas) → review+
(Assignee)

Comment 16

7 years ago
Created attachment 468537 [details] [diff] [review]
v3, fixes regex and makes it an OR not and AND

Right, covers 4.0$ case and also makes this an OR.  AND would have no matches since you can only have on version at a time!
Attachment #468537 - Flags: review?(nrthomas)
(Assignee)

Comment 17

7 years ago
Created attachment 468548 [details] [diff] [review]
v4, fixes preg_match, works based on tests
Attachment #468530 - Attachment is obsolete: true
Attachment #468537 - Attachment is obsolete: true
Attachment #468548 - Flags: review?(nrthomas)
Attachment #468537 - Flags: review?(nrthomas)
(Assignee)

Comment 18

7 years ago
v4 checked in based on tests and r=nthomas.  We're testing it in staging right now.

Checking in index.php;
/cvsroot/mozilla/webtools/aus/xml/index.php,v  <--  index.php
new revision: 1.28; previous revision: 1.27
done
I performed the following set of tests:

PPC Machine:

Downloaded a fresh copy of Firefox 4 B3 from the releases directory.
Connected to the MPT
Changed to the staging URL-> http://aus2-staging.mozilla.org/
Confirmed that I was connected to the server
Help->Check for Updates
No update found

Downloaded a fresh copy of FF 3.6.7 from the releases directory
Connected to the MPT
Changed to the staging URL-> http://aus2-staging.mozilla.org/
Confirmed that I was connected to the server
Help->Check for Updates
Update to 3.6.8 found

Intel:

Downloaded a fresh copy of FF 4 Beta 3
Changed the channel to betatest
Connected to the MPT
Changed to the staging URL-> http://aus2-staging.mozilla.org/
Confirmed that I was connected to the server
Help->Check for Updates
Update to Beta 4 found
(Assignee)

Comment 20

7 years ago
Thanks so much Marcia.  I'll file push bug for prod.
(Assignee)

Updated

7 years ago
Depends on: 590014
(Assignee)

Comment 21

7 years ago
This was pushed.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Attachment #468548 - Flags: review?(nrthomas) → review+
Thanks everyone. Super awesome!
This will still block updates for beta 5, right?
Yes, any version matching 4.0* or 3.7*.

Updated

7 years ago
Blocks: 601919
You need to log in before you can comment on or make changes to this bug.