Last Comment Bug 587799 - [PPC] Minefield won't load any sites using latest trunk nightly
: [PPC] Minefield won't load any sites using latest trunk nightly
Status: RESOLVED WORKSFORME
: regression, relnote
Product: Toolkit
Classification: Components
Component: Safe Browsing (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- critical with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 611980 (view as bug list)
Depends on:
Blocks: 587771 588412 600965
  Show dependency treegraph
 
Reported: 2010-08-16 14:12 PDT by Marcia Knous [:marcia - use ni]
Modified: 2014-05-27 12:25 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments

Description Marcia Knous [:marcia - use ni] 2010-08-16 14:12:48 PDT
Seen while running Mozilla/5.0 (Macintosh; PPC Mac OS X 10.5; rv:2.0b4pre) Gecko/20100816 Minefield/4.0b4pre

STR:
1. Try to load any web site.
2. Receive this error: Error: uncaught exception: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://browser/content/safebrowsing/sb-loader.js :: anonymous :: line 48"  data: no]

Although I believe I have heard the PPC has an uncertain future, would it be weird if this was broken in B4 yet worked in B3?
Comment 1 Marcia Knous [:marcia - use ni] 2010-08-16 14:23:21 PDT
I also found I cannot create a new profile on that machine as well, so I could only test with an existing profile that I had that worked fine on Friday.
Comment 2 Marcia Knous [:marcia - use ni] 2010-08-17 10:11:02 PDT
I thought I nominated this yesterday, but doing so now so release drivers can evaluate it.
Comment 3 Marcia Knous [:marcia - use ni] 2010-08-17 10:19:58 PDT
Error: (void 0) is undefined
Source File: file:///Users/mozilla/Desktop/Minefield.app/Contents/MacOS/components/nsPlacesAutoComplete.js
Line: 842 is the other error that shows up consistently in the console using the latest nightly from 8/17.
Comment 4 David Dahl :ddahl 2010-08-17 11:05:16 PDT
(In reply to comment #0)
> Although I believe I have heard the PPC has an uncertain future, would it be
> weird if this was broken in B4 yet worked in B3?

That would not be strange as there are tm-merges during each beta release. We might want to cc some JS folks.
Comment 5 Robert Sayre 2010-08-17 12:13:03 PDT
I bet this is from YARR. sigh.
Comment 6 Robert Sayre 2010-08-17 12:13:38 PDT
Worryingly, this means we have precisely zero automated coverage of PPC. So, we really have no idea what we are shipping to those users.
Comment 7 Mike Shaver (:shaver -- probably not reading bugmail closely) 2010-08-17 12:16:02 PDT
I really don't think we should ship PPC to users for FF4; I think we're just waiting for the x64 stuff to be ready, so that we can switch to x32/x64 from PPC/x32.  I will...investigate that!
Comment 8 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2010-08-17 18:23:09 PDT
(In reply to comment #6)
> Worryingly, this means we have precisely zero automated coverage of PPC. So, we
> really have no idea what we are shipping to those users.

As usual, automated PPC unittest runs are on http://tinderbox.mozilla.org/showbuilds.cgi?tree=GeriatricMachines. Not sure what specific test suite would have shown this problem, but all the unittests are being run as fast as these old machines will allow.

Let me know if you need further details.
Comment 9 Mike Beltzner [:beltzner, not reading bugmail] 2010-08-18 07:56:46 PDT
(In reply to comment #8)
> As usual, automated PPC unittest runs are on
> http://tinderbox.mozilla.org/showbuilds.cgi?tree=GeriatricMachines. Not sure
> what specific test suite would have shown this problem, but all the unittests
> are being run as fast as these old machines will allow.

Well, if the builds didn't start up, I would have expected the tests to go red as they wouldn't have been able to start. Those tests aren't reported to the main Tinderbox, is what I think Rob is saying, so we're not paying attention to them.

Good to know they're there.

I filed bug 588412 on ensuring we don't offer Beta 4 updates to PPC users.
Comment 10 Stefan [:stefanh] (away until May 28) 2010-08-23 06:36:26 PDT
See also bug 587771.
Comment 11 Mike Beltzner [:beltzner, not reading bugmail] 2010-08-31 12:31:27 PDT
We have decided to drop support for PPC/OSX for Firefox 4, so this doesn't block.
Comment 12 Ludovic Hirlimann [:Usul] 2010-08-31 21:54:28 PDT
(In reply to comment #11)
> We have decided to drop support for PPC/OSX for Firefox 4, so this doesn't
> block.

Mike is there a plan to announce that more widely ?
Comment 13 Karsten Düsterloh 2010-08-31 23:13:42 PDT
(In reply to comment #12)
> Mike is there a plan to announce that more widely ?

Especially since the patch in bug 587612 might fix the issue here as well?
Comment 14 Mike Beltzner [:beltzner, not reading bugmail] 2010-09-07 11:38:15 PDT
This has now been announced more widely: http://wiki.mozilla.org/Firefox/4/Platforms
Comment 15 Robert Kaiser (not working on stability any more) 2010-10-05 05:39:02 PDT
Strange that this bug is in safebrowsing as apparently we are seeing this in SeaMonkey as well.
Comment 16 Marcia Knous [:marcia - use ni] 2010-10-20 16:42:39 PDT
Now that this has been announced, can we close out this bug?
Comment 17 Mike Beltzner [:beltzner, not reading bugmail] 2010-10-20 23:24:57 PDT
This bug isn't a blocker, but if someone comes along with a patch that fixes it or its dependencies we would probably take them.
Comment 18 Mike Shaver (:shaver -- probably not reading bugmail closely) 2010-11-03 01:06:56 PDT
Did this get resolved by bug 587612?
Comment 19 Tim (fmdeveloper) 2010-11-13 13:20:48 PST
*** Bug 611980 has been marked as a duplicate of this bug. ***
Comment 20 Cameron Kaiser [:spectre] 2010-11-20 18:19:09 PST
Yes, it was fixed by bug 587612 (G5 running 4.0b8pre).
Comment 21 Jens-Erik Weber 2011-02-08 08:05:17 PST
(In reply to comment #14)
> This [drop of PPC support] has now been announced more widely:
> http://wiki.mozilla.org/Firefox/4/Platforms

This says “universal binary” and on the other hand “CPU architecture: i386, x86-64”. That's a contradiction!
Comment 22 Ludovic Hirlimann [:Usul] 2011-02-16 08:00:47 PST
(In reply to comment #21)
> (In reply to comment #14)
> > This [drop of PPC support] has now been announced more widely:
> > http://wiki.mozilla.org/Firefox/4/Platforms
> 
> This says “universal binary” and on the other hand “CPU architecture: i386,
> x86-64”. That's a contradiction!

from https://secure.wikimedia.org/wikipedia/en/wiki/Universal_binary

With the release of Mac OS X Snow Leopard and the move to 64-bit architecture, Universal can also mean an application that runs natively on i386 (32-bit Intel) and x86_64 systems.
Comment 23 Terrell Kelley 2011-03-09 22:04:06 PST
This bug is listed as a known issue on the RC, but comments seem to indicate that this might be fixed. Could anyone confirm either way? We don't want to claim we don't have PPC support if we do.
Comment 24 Stefan [:stefanh] (away until May 28) 2011-03-10 09:30:16 PST
(In reply to comment #23)
> This bug is listed as a known issue on the RC, but comments seem to indicate
> that this might be fixed. Could anyone confirm either way? We don't want to
> claim we don't have PPC support if we do.

See comment #11. Also, the RC binary is an i386/x86_64 universal build, so it won't run on a PPC machine.
Comment 25 Terrell Kelley 2011-03-10 12:13:36 PST
I am aware that the current Mac-build is incompatible with PPC. but Comment 17 made it sound like a PPC version would be offered in some form if this bug was fixed. And Comment 19 says it was.

Perhaps he only meant that it might be fixed for a contributed build?
Comment 26 Cameron Kaiser [:spectre] 2011-03-10 20:34:29 PST
If you mean me (comment 20), I'm referring to both the El Furbe PPC builds and TenFourFox, both of which do run (this post is from TenFourFox on an iBook G4).
Comment 27 Terrell Kelley 2011-03-11 10:43:29 PST
(In reply to comment #26)

Yes, I meant you. Sorry. So my question becomes: Would it be possible for either of those builds to be under "contributed builds"? It would seem to be the same type of thing as allowing Solaris builds there.

If not, I understand, and thank Mr. Kaiser for telling me where I can get a PPC build. I have been "spreading the gospel" about Firefox 4, and now I know I can share with my friends who still use PPC-based Macs.
Comment 28 Matthias Versen [:Matti] 2012-12-28 12:02:23 PST
marking wfm based on comment#20
Comment 29 Terrell Kelley 2013-01-08 20:04:29 PST
Note for the future: this bug having been fixed doesn't mean that official builds of Firefox run on PPC (e.g. G3, G4, G5) Macs. TenFourFox is the only way to use as much of the latest Firefox code as possible, and, even there, current builds no longer allow the use of plugins.

Note You need to log in before you can comment on or make changes to this bug.