Closed Bug 588463 Opened 10 years ago Closed 10 years ago

Cannot update Linux Nightly from Aug 17 to Aug 18

Categories

(Toolkit :: Application Update, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- -

People

(Reporter: cmtalbert, Unassigned)

Details

I'm not sure what is going on here, but I'm running 32bit Ubuntu 10.4 on a 64bit x86 chipset.  That might be what confused Firefox.  I've been updating from nightly to nightly with no issues for a long time now.

However, today I did the following:
1. Install (from ftp.mozilla.org) the 32 bit August 17 nightly
2. Click "Check for updates" and allow the updater to go ahead
3. It starts installing the aug 18 update

= Actual Behavior =
* The updater throws up an Alert dialog (looks like a JS alert) stating "The operation could not be completed because of an internal failure. A secure network communication has not been cleaned up properly".
* Once you click "OK" the browser loads but is unable to render any content.  It's unusable.

= Expected Behavior =
* You update and all things keep working properly.
* If there is an issue with updating, throwing up a javascript alert dialog is probably not the way we want to go.

= Other notes =  
* You can download the August 18 build and it works fine.  This is only an issue with the updater.
* Ted believes it might be an issue related to omnijar, but other users I've spoken with do not see this issue on their linux boxes.

Marking this as critical because it prevents people from dog-fooding a release, and we should correct any and all issues in our updater code to be as resilient as possible.
blocking2.0: --- → ?
Did you also see the extension compatibility wizard? I suspect the alert is from that especially since the app update process doesn't connect to the network during startup and I also saw this alert without performing an update late last night. Also, Ted may very well be correct regarding omnijar breaking rendering content, etc.
saw the alert after seeing the extension compatibility wizard that is.

btw: does restarting Firefox render content? Does uninstalling / re-installing fix it? If you haven't re-installed yet, could you move the existing install out of the way by renaming the directory and install today's build to check that?
(In reply to comment #2)
> saw the alert after seeing the extension compatibility wizard that is.
> 
Yes, I did see the compatibility wizard right before this dialog box came up.  Maybe that's what caused it.

> btw: does restarting Firefox render content? 
Yes, it does.  I should have tried that first, I guess :)

Does uninstalling / re-installing
> fix it? If you haven't re-installed yet, could you move the existing install
> out of the way by renaming the directory and install today's build to check
> that?
Yes, uninstalling and reinstalling the Aug 18 build will fix the issue.  This only happens during update.

Another interesting thing I just found while reproducing the error: if you let the alert dialog sit there for a couple of minutes then you don't see the issue.  Perhaps the OS takes care of the rogue network connection and all is well?

Downgrading to "normal" as this doesn't seem like a critical issue anymore due to the above workarounds.
Severity: critical → normal
Looks like this is where that alert is coming from: http://mxr.mozilla.org/mozilla-central/source/security/manager/ssl/src/nsNSSComponent.cpp#2304
From the response, I highly suspect that everything you have reported is outside of the app update code.
Should I move this to the compatibility checker component?  Where does that live in bugzilla?
I'd like to verify the cause before moving this bug though I don't know when I will have time to diagnose. Also, it might be better to file individual bug reports... one for the content not being displayed (no idea what causes that) and one for the alert (likely the add-ons manager since it re-enabled the compatibility check wizard yesterday, I saw the same alert after seeing that UI without an update, etc.).
I went ahead and filed bug 588511 for the alert.
(In reply to comment #0)
> ... an Alert dialog (looks like a JS alert) stating "The
> operation could not be completed because of an internal failure. A secure
> network communication has not been cleaned up properly".

Interesting, I get that fairly frequently in Thunderbird when _exiting_. Seems like a dialog we should kill off, though, since it's not really helpful to the user.
Clint, the alert is being handled by bug 588511 and I'm quite certain that "Once you click "OK" the browser loads but is unable to render any content. It's unusable." isn't an app update bug. If you are still able to reproduce this second part could you file a bug for that one issue? Perhaps Firefox -> General for triage if you are unable to find a better component.
I'm leaving this around for a bit because of the "its unusable" bit. Is it able to render HTTP content, but not HTTPS? That would indicate that bug 588511 will fix the entire problem. Otherwise, we'll need to investigate more.
Want more confirmation of the problem here before blocking.
blocking2.0: ? → -
Clint, is this still happening?

Does anyone know of any other reports of this happening? No dupes makes me think this might have been a fluke possibly brought on by bug 588511 or another bug.
I haven't seen any other reports of this happening beyond what happens with bug 588511. It appears that bug 588511 (see bug 588511 comment #26) also prevents surfing the web which may be the other problem reported in this bug.
No other reports and since this is likely a side affect of bug 588511 resolving as wfm.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.