Crash opening .doc file in helper app

VERIFIED DUPLICATE of bug 44762

Status

defect
P3
critical
VERIFIED DUPLICATE of bug 44762
19 years ago
15 years ago

People

(Reporter: selmer, Assigned: mscott)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm need info])

Reporter

Description

19 years ago
11/01 limbo 2

From mail message, open doc file attachment (something/msword mime type)
On save/open dialog choose open
A save-as dialog opens _behind_ the main window!
On this dialog, choose to save
On file picker, pick location and hit save
crash at <unknown> dll!

Talkback ID = TB20248737X
Reporter

Comment 1

19 years ago
Getting a save as dialog after asking for an open seems wrong.  Adding crash and
rtm keywords.
Keywords: crash, rtm
Whiteboard: [rtm need info]
Reporter

Comment 2

19 years ago
Second attempt also crashes but I got a dll in the message: msgbsutil
Talkback ID = TB20249418K
Reporter

Comment 3

19 years ago
If I don't try to open the doc, I don't crash (choose save directly.)  The path
doesn't go through the unknown content type handler either.  I thought we
eliminated the unknown content type handler with your PR3 checkin, is this just
a path we missed or something?

Comment 4

19 years ago
I tried this with win32 & linux build 2000-11-01-09 and the mac 2000-11-01-08
build and it doesn't crash for me.  It saves the file.  I used an existing
profile.  I will try this again with the builds from last night and update.
selmer: did you try with a new profile?
Severity: normal → critical

Comment 6

19 years ago
Update,  I took the limbo2 builds 2000-11-01-20 on win98 and linux.  I still
have not crashed saving a word doc.  I tried this using the scenario and
bypassing the open file selection going straight to "Save it to disk"  both work
fine.  Steve, can you email me your document and I'll try with that.  Also note,
my Save as dialog open up front.  
Reporter

Comment 7

19 years ago
Haven't tried a new profile yet.  May not have time this morning, fatherly
duties are calling...

Esther, did you get application/msword as the mime type?  I suppose it could be
the actual document contents, but that seems amazing to me.  I'll email you the
doc, the contents cannot be made public.
Reporter

Comment 8

19 years ago
OK, back for a minute.  I think the difference is that I don't actually have
word installed.  I'm on a consumer win98 and it has wordpad instead.  I was
expecting to be able to pick the app, but it didn't let me do that.  I was only
given the choice of saving the file and then it crashed.

Esther, if you have a machine without word installed you could test there.
Otherwise, probably any type of file you don't already have registered would
exhibit this problem.

Comment 9

19 years ago
I have Word intstalled, but I too get the message that it can't open
it(emp_req.doc) because it is of a mime type application/msword and Netscape 6
can't view it, so it give me the option to open it with another application (at
this point "word" in in the text box).  I then click on Save and get the "Save
attachment" dialog.  I will try to find a system without Word so it doesn't find
an alternative app for opening this. 

Comment 10

19 years ago
I just realized, that my linux doesn't have Word on it and doesn't give me a
suggested app to try.  It doesn't crash.  Still looking for a PC without
Word, but I'm thinking it could be something in the .doc file, so let me send
you my mail message with the doc file for you to try.
Assignee

Comment 11

19 years ago
this is a dup. 

*** This bug has been marked as a duplicate of 44762 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.