If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Direct2D broken on D3D9 hardware since 2010-08-11

RESOLVED DUPLICATE of bug 587566

Status

()

Core
Graphics
--
major
RESOLVED DUPLICATE of bug 587566
7 years ago
7 years ago

People

(Reporter: Hans Schmucker, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100818 Minefield/4.0b2pre ( LIKE Firefox/3.6 )
Build Identifier: Gecko/20100811

There's little information other than it works in the 2010-08-10 build, but is broken in 2010-80-11. Didn't notice it until D2D had been re-enabled and the tinderbox builds are not available anymore.

It should be in this range: http://hg.mozilla.org/mozilla-central/pushloghtml?enddate=2010-08-12&startdate=2010-08-09 

Tested only on my Windows7 system using a GeForce 7900 Go GS (which works perfectly in the 2010-08-10 build).

Reproducible: Always

Steps to Reproduce:
1. Install 2010-08-10
2. Enable D2D with render-mode and directwrite
3. Check if D2D is enabled
4. Install 2010-08-11
5. Check if D2D is enabled
Actual Results:  
No acceleration in 2010-08-11

Expected Results:  
Acceleration in 2010-08-11
(Reporter)

Updated

7 years ago
Blocks: 527707
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
There's already a fix to this in bug 587566.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587566
(Reporter)

Comment 2

7 years ago
Sorry, at some point we really need tags in Bugzilla. I was searching for "D3D9" and "DX9", not "non-DX10" or "non-D3D10"
You need to log in before you can comment on or make changes to this bug.