Restarting with just App Tabs open when set to "Show my windows and tabs from last time" opens home page

RESOLVED WONTFIX

Status

()

Firefox
Session Restore
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: Spencer Selander [greenknight], Assigned: zpao)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100818 Minefield/4.0b5pre ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100818 Minefield/4.0b5pre ( .NET CLR 3.5.30729)

If I close Minefield with only App Tabs open, when I restart my home page opens as well in a normal tab which has focus. If I have a home page App Tab, still opens another normal tab of my home page.



Reproducible: Always

Steps to Reproduce:
1.Create one or more App Tabs.
2.Set Minefield to "Show my windows and tabs from last time".  
3.Close all other tabs, including those in tab sets not currently displayed.
4.Restart Minefield
Actual Results:  
Minefield spawns a new normal tab open to my home page, which has focus over the App Tab(s).

Expected Results:  
Should restore just what was open when browser was closed, whether it was an App Tab or not.

This happened even with a new, clean profile. I first saw this in the 20100814 nightly, iirc; I'm on dial up, so it would take me too long to check the regression window.  I have a report this also happens in Linux.
blocking2.0: --- → ?
Keywords: regression, regressionwindow-wanted
Version: unspecified → Trunk
see also bug 580512
What are your history settings?
(Reporter)

Comment 3

8 years ago
History setting is default, "Remember history".
Please renominate if we get a confirmation; I don't see this. If I set Firefox to always restore my session (step 2 in the comment 0 STR) then I get full on session restore.
blocking2.0: ? → ---

Comment 5

8 years ago
Confirmed. I have the same experience. If all tabs are set as App Tabs, my home page will also open on a cold start. If I change one of my App Tabs to a Normal Tab, it opens as a normal tab and my home does not open. Startup option set to "Show my windows and tabs from last time".
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed on XP, if I have only gmail in an apptab, and have session restore to "Show my windows and tabs from last time"; when I restart the apptab is there but my home page is also, and the home page has focus.
Thanks for the confirmations, gents. Anyone want to fetch us a regression range?
blocking2.0: --- → betaN+
Will work on one based on the date in comment 0 - check back soonish
Regression range on XP:
Comment 0 was bang on.

works	2010-08-13-04	http://hg.mozilla.org/mozilla-central/rev/d5e211bdd793
broken	2010-08-14-04 	http://hg.mozilla.org/mozilla-central/rev/656d99ca089c

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d5e211bdd793&tochange=656d99ca089c

Can't find any hourlies back that far so rather a large messy range of checkins for someone with more nous than me to determine the culprit.
Possibly: Dão Gottwald — Bug 580512 - App tabs should outlive normal sessions.
I think this is expected behavior from bug 580512 - we're working under the assumption that if all you had open was app tabs, then you ended your session. So we restore your app tabs & start a new session (which is your home page), much like if you exited while ending your session pre-app tabs.

Perhaps if it's the case that you have your prefs to Restore Session, that we only restore your app tabs...
Keywords: regressionwindow-wanted
(Reporter)

Comment 12

8 years ago
Now it's just opening a new tab that's blank. Somewhat of an improvement, I guess.
(Reporter)

Comment 13

8 years ago
(In reply to comment #12)
> Now it's just opening a new tab that's blank. Somewhat of an improvement, I
> guess.

My mistake, nothing's changed. Pref somehow got reset to open with a blank page - stupid of me not to have checked that.
(Reporter)

Comment 14

8 years ago
Just created a new profile, and with it I'm not seeing this behavior. With any previously created profile, including a totally clean one with all settings default, it still occurs.
Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre ID:20101012041851
(Reporter)

Comment 15

8 years ago
(In reply to comment #14)
> Just created a new profile, and with it I'm not seeing this behavior. With any
> previously created profile, including a totally clean one with all settings
> default, it still occurs.
> Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre
> ID:20101012041851

Well, that didn't last; this profile is now exhibiting the bug. In several restarts of the browser the first day it didn't happen, but now it does - took a reboot to start it, apparently.

An aberration, it seems; another newly-created profiled showed this bug immediately. Sorry I brought it up.
Assignee: nobody → paul
I'm still not completely convinced that we shouldn't show your home page. App tabs are supposed to be independent from session - if you have prefs to not save session, we'll still restore your app tabs.

In the case of this bug, you've "ended your session" and left no normal tabs open, but your app tabs would remain regardless. So I still think this should count as a new session when starting up.

Alex, I know you're probably still digging yourself out of a big bugmail pile, but do you have any thoughts here?
OS: Windows XP → All
Hardware: x86 → All
Until we get a home tab, I don't see a good alternative.  Users are going to expect to get their home page on launch (although it is a bit awkward that we have a to spawn a new normal tab in order to display it).
Per above, this is the behavior we expect. When we have a proper home tab this will be less awkward.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 613431
Duplicate of this bug: 633148

Comment 21

8 years ago
I think this should be fixed. With this bug, app tabs usage is severelly limited.

Comment 22

7 years ago
I agree with Michal Illich. It was the first thing I wanted to set when I first learned about App tabs today.

App tabs will per definition be the most used websites, so why force another (or duplcate) site as start page?

Comment 23

7 years ago
I agree - let me use an App Tab as my homepage - don't open a new tab of my homepage if it is already in the App Tab

Comment 24

7 years ago
What about when closing the last regular tab that instead of closing, the homepage was loaded, this was the behavior before. This would help not have the jarring effect when opening Firefox with a new tab ope. either that or inject some code into the session on shutdown so Firefox thinks the tab was already open from a previous session.
Duplicate of this bug: 644809

Comment 26

7 years ago
It's not clear to me that bug 633148 is really a duplicate of this bug, though the underlying issue is the same. I would summarize bug 633148 as "Let me use an app tab as my homepage". (Or to put it another way, "Let me choose to have NO homepage if I have app tabs." That summary would encompass this bug, too.) As viewed from those bugs, the issue has nothing to do with the "Show my windows and tabs from last time" preference that is the focus here.

Comment 18 indicates that a "proper home tab" will make this moot, which sounds plausible to me, but I don't know the details. What's the bug number on that? Is there an estimate on when it will land?
(In reply to Steuard Jensen from comment #26)
> Comment 18 indicates that a "proper home tab" will make this moot, which
> sounds plausible to me, but I don't know the details. What's the bug number
> on that? Is there an estimate on when it will land?

Bug 544819, but not ETA at the moment. It's blocked on some underlying issues we're trying to work through.
(Reporter)

Comment 28

7 years ago
(In reply to Steuard Jensen from comment #26)
> It's not clear to me that bug 633148 is really a duplicate of this bug,
> though the underlying issue is the same. I would summarize bug 633148 as
> "Let me use an app tab as my homepage". (Or to put it another way, "Let me
> choose to have NO homepage if I have app tabs." That summary would encompass
> this bug, too.) As viewed from those bugs, the issue has nothing to do with
> the "Show my windows and tabs from last time" preference that is the focus
> here.
> 
> Comment 18 indicates that a "proper home tab" will make this moot, which
> sounds plausible to me, but I don't know the details. What's the bug number
> on that? Is there an estimate on when it will land?

As the reporter of this bug, I would say that bug 633148 is an exact duplicate. I was trying to use an app tab as my homepage when I discovered the bug. I summarized it differently, but it's the same issue.

In the mean time, you can use an app tab for a home tab - you just have to set the Home Page pref to some other site. Sad to hear there's no ETA on a proper home tab.

Comment 29

5 years ago
This was reported back in Firefox 4 days. Now it is 17 major versions later and this bug is still not fixed. Maybe you can fix it as part of Firefox 25 redesign? https://wiki.mozilla.org/Firefox/Features/Theme_Refinement_and_Evolution_%28Australis%29
You need to log in before you can comment on or make changes to this bug.