Don't load a duplicate "Home page" Tab if it was an AppTab(Pinned Tab) in previous session

RESOLVED DUPLICATE of bug 588733

Status

()

--
major
RESOLVED DUPLICATE of bug 588733
8 years ago
8 years ago

People

(Reporter: rob64rock, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101118 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101118 Firefox/4.0b8pre

When using setting "Show my windows and tabs from last time" and you AppTab(pinned tab) your "Home page" it shouldn't be duplicated after restart. Since, AppTabs(pinned Tabs) restore regardless if that setting is set or not it doesn't make any since for it to be duplicated just for it to be instantly closed since it's already loaded has an AppTab(pinned Tab).

Reproducible: Always

Steps to Reproduce:
1.Set setting "Show my windows and tabs from last time"
2.Load your "Home page" then AppTab(pinned Tab) it.
3.restart browser.
Actual Results:  
After restart you get a AppTab(pinned Tab) of your "Home page" and and newly loaded regular "Home page" tab. 

Expected Results:  
After restart your "Home page" AppTab(pinned Tab) shouldn't be duplicated as a regular Tab since, it's already loaded has AppTab(pinned Tab). Preventing the need of having to close it every time at restart.

I know this was probably mention here: https://bugzilla.mozilla.org/show_bug.cgi?id=588733

AppTabs(pinned Tabs) of any kind shouldn't be duplicated as regular tabs at start up. That defeats the purpose of making them AppTabs(pinned Tabs) in first place.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
Edited: Typo
> Expected Results:  
> After restart your "Home page" AppTab(pinned Tab) shouldn't be duplicated as a
> regular Tab since, it's already loaded has AppTab(pinned Tab). Preventing the
> need of having to close it every time at startup.

Comment 2

8 years ago
Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110116 Firefox/4.0b10pre

Was able to reproduce issue on nightly build, but it looks that this issue won't be fixed. See Bug 588733.
Dupe of bug 588733?
Whiteboard: dupeme?

Comment 4

8 years ago
(In reply to comment #3)
> Dupe of bug 588733?

Different situation I reckon.
It's a dupe of bug 588733.
Blocks: 551849
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Whiteboard: dupeme?
Duplicate of bug: 588733
You need to log in before you can comment on or make changes to this bug.