[OOPP] Support i386 plugins on x86_64 arch (Linux)

RESOLVED INCOMPLETE

Status

()

Core
Plug-ins
RESOLVED INCOMPLETE
7 years ago
3 months ago

People

(Reporter: Martin Stránský, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
It would be great if firefox can provide similar feature like nsplutinwrapper, i.e. to run 32-bit plugins by 64-bit browser.
(Reporter)

Updated

7 years ago
Blocks: 478976
Depends on: 559142

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
No longer depends on: 559142
Resolution: --- → DUPLICATE
Duplicate of bug: 559142
Let's keep this bug about Linux.
Status: RESOLVED → REOPENED
Component: IPC → Plug-ins
QA Contact: ipc → plugins
Resolution: DUPLICATE → ---
Summary: [OOPP] Support i386 plugins on x86_64 arch → [OOPP] Support i386 plugins on x86_64 arch (Linux)
nspluginwrapper on Linux seems to be rather dead and with OOPP it shouldn't be needed anymore. It seems to be quite unstable with recent Linux systems also.
Adobe even removed their alpha release of the x86-64 plugin.
(Reporter)

Comment 4

7 years ago
There are still i386 only plug-ins (like Adobe reader). And there isn't a difference between "cross-arch" i386:x86-64 and i386:i386/x86-64:x86-64 from stability perspective. If i386:i386/x86-64:x86-64 works fine under OOPP, cross-arch should work fine too.

Comment 5

7 years ago
Except when you go from x86_64 > i386 you have to make sure you don't overflow as the variables is in different length.

This isn't the place for this discussion though.

Comment 6

7 years ago
(In reply to comment #5)
> Except when you go from x86_64 > i386 you have to make sure you don't overflow
> as the variables is in different length.

Err no, only pointers and size_t are different sizes on x86_64 int is still 32 bit. I don't know anything about how the wire format of the remoting looks, but you aren't going to be passing pointers over it since that won't work, and I doubt anything that is passed over it is a different size between archs. So basically, no that is almost certainly a non-issue.

Comment 7

7 years ago
I'm quite keen to see this work on Linux too, I'd like to make nspluginwrapper disappear entirely. The Flash experience it provides for 64-bit users is currently pretty bad.

Is anybody planning to work on this?
http://labs.adobe.com/technologies/flashplayer10/

Adobe® Flash® Player "Square" is a preview release that enables native 64-bit support on Linux, Mac OS, and Windows operating systems, as well as enhanced support for Microsoft Internet Explorer 9 beta.
There was a 64 bit beta preview of the flash player before.
But that was unsupported security wise...
As that could happen again it's not expected that linux distributions will
integrate this beta.

So only if firefox would support 32 bit plugins with a 64 bit browser, like it does for mac osx (bug 559142), nspluginwrapper would not be needed any more.

Comment 10

5 years ago
Linux has Integrated support for cross-architecture installation of binary packages (particularly i386<->amd64, but also other combinations)
So now only if firefox would support 32 bit plugins with a 64 bit browser
Resolving old bugs which are likely not relevant any more, since NPAPI plugins are deprecated.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago3 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.