bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[OOPP] add support for using i386 plugins from an x86_64 host

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Dolske, Assigned: Josh Aas)

Tracking

unspecified
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

8 years ago
OS X comes with Flash and QuickTime pre-bundled (in /Library/Internet Plugins/). However, these are both 32 bit binaries (even on 10.6), and so the new 64-bit Firefox builds don't use them. This has the potential for sucking from a UX pov, because Flash/QT stop working if a user installs a 64-bit Firefox. Clearly we'd need to address this before ever automatically updating someone to a 64-bit build, and it's a bit undesirable for new installs too (though not much worse than other platforms which don't bundle these plugins).

Not sure what the options are here...

* Work with Apple to get 64-bit versions of these plugins preinstalled?
* Roll our own system to install 64-bit Flash? [Doesn't help w/QT]
* Make the OOPP plugin-container process 32 bit?

Updated

8 years ago
Duplicate of this bug: 558426
Josh, I'm assuming this is a dupe, can you please mark as such if that's the case?
Assignee: nobody → joshmoz
blocking2.0: ? → final+
(Assignee)

Comment 3

8 years ago
The existing Quicktime and Flash plugins won't run out-of-process, and thus we can't do any sort of cross-architecture load. We 'll be solving this problem by getting newer versions of the plugins and adding them to PFS, which is our system for delivering uninstalled plugins to users. We may, in the Flash case, investigate running 32-bit Flash 10.1 OOP in the 64-bit browser, but that doesn't solve the problem in the summary here, which refers to OS-bundled plugins. Updating bundled plugins is Apple's issue, not ours.

We can leave this bug open if you want, but I don't think it'll track work we're planning to do.
Assignee: joshmoz → nobody

Updated

8 years ago
Duplicate of this bug: 575972

Updated

8 years ago
Assignee: nobody → joshmoz

Updated

8 years ago
Duplicate of this bug: 581839

Comment 6

8 years ago
I've run into this problem, and I'm confused by the response.  

Referring to your comment, "The existing Quicktime and Flash plugins won't run out-of-process," it appears that this is exactly what Safari does already.  If you run 64-bit Safari and view a flash video, one finds in the process table a 32-bit container for the Flash plugin.  

Considering that you made this comment 3 months ago, is it just out of date?  I'm referring to Safari 5.x.
(Assignee)

Updated

8 years ago
Summary: 64-bit Firefox can't use OSX-bundled plugins (Flash, QuickTime) → 64-bit Firefox for Mac OS X can't use 32-bit plugins
(Assignee)

Updated

8 years ago
Depends on: 578868
(Assignee)

Comment 7

8 years ago
Created attachment 464699 [details] [diff] [review]
fix v0.1

Just saving off part of the work so far. This along with the patch in bug 578868 will get the browser recognizing the proper set of plugins based on available architecture options.
what about Windows/Linux platforms ?

Comment 9

8 years ago
(In reply to comment #8)
> what about Windows/Linux platforms ?

I would be inclined to provide separate tickets for each platform, and then just leave this ticket to focus on the MacOS X platform. I'll let Josh make the call here.
Blocks: 588749
(Assignee)

Updated

8 years ago
Summary: 64-bit Firefox for Mac OS X can't use 32-bit plugins → [OOPP] add support for using i386 plugins from an x86_64 host
(Assignee)

Updated

8 years ago
No longer blocks: 588749
Duplicate of this bug: 588749
(Assignee)

Updated

8 years ago
Depends on: 590052, 590054
(Assignee)

Updated

8 years ago
Attachment #464699 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Depends on: 590057

Comment 11

8 years ago
This is not Mac-specific (at least Linux is affected as well).
OS: Mac OS X → All

Comment 12

8 years ago
*This* bug is mac-specific.
OS: All → Mac OS X
bug 588749 (that Josh just duped), was pretty clearly about Linux. I agree that they're different sets of work, but we should keep the bugs separate if they are.
OS: Mac OS X → All

Updated

8 years ago
OS: All → Mac OS X
(Assignee)

Updated

8 years ago
Blocks: 571367
(Assignee)

Updated

8 years ago
Depends on: 590857
(Assignee)

Updated

8 years ago
Depends on: 596434

Comment 14

8 years ago
There is now a beta version of a 64bit Flash plugin for Mac OS X, that works nice with an 64bit FF (b6) version.
http://labs.adobe.com/downloads/flashplayer10.html

Comment 15

8 years ago
Is Firefox smart about loading 32-bit plugins into 32-bit processes and 64-bit plugins into 64-bit processes?  Or does it just assume one and fail at the other?
(Assignee)

Comment 16

8 years ago
(In reply to comment #15)
> Is Firefox smart about loading 32-bit plugins into 32-bit processes and 64-bit
> plugins into 64-bit processes?  Or does it just assume one and fail at the
> other?

It's smart (enough, I think), and the architecture of the host is preferred. Most of that logic is in the patch on bug 590057, we'll have a little more work to do in bugs like 596762.
(Assignee)

Comment 17

8 years ago
Checked in the last dependency to make this work on mozilla-central, resolving fixed. If there are issues with this feature please file separate bugs.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 18

8 years ago
I'm a little confused about this bug. If running Firefox in 64-bit should it be able to use 32-bit plugins or only 64-bit ones? Currently the only plugin listed in about:plugins is the Java plugin.

If the plan is to make i386/x86_64 builds for release the above will cause problems for those running an Intel-based Mac (except Core Duo models) as it will default to loading Firefox in 64-bit.

Comment 19

8 years ago
If using OOP plugins, then it is to allow 64-bit Firefox to run both 32-bit and 64-bit plugins. I am not sure which beta build this functionality it meant to be available in though.
This bug only added code support for running 32-bit plugins in a 32/64 universal build. We aren't producing that kind of universal builds yet, that's bug 571367.

Comment 21

8 years ago
To this user the bug is definitely *not* fixed. The answer is given in Comment 14 from Nomis101: "There is now a beta version of a 64bit Flash plugin for Mac OS X, that works nice with an 64bit FF (b6) version.
http://labs.adobe.com/downloads/flashplayer10.html"

The ongoing problem (or a different bug?) is that FF directs users to a plugin that doesn't work.

Comment 22

8 years ago
Apparently you're using b6 - but the code for running 32-bit plugins with a 64-bit Firefox is only available in nightly builds so far (b7pre).
You need to log in before you can comment on or make changes to this bug.